Download it now!
Bug 121639 - RTF rendering a hyperlink fails in version 6.1.3.2
Summary: RTF rendering a hyperlink fails in version 6.1.3.2
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:rtf
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2018-11-22 19:42 UTC by poul.steen
Modified: 2019-05-13 15:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This file demonstrates the lack of rendering a hyperlink correctly in LibreOffice Writer version 6.1.3.2. (811 bytes, text/rtf)
2018-11-22 19:42 UTC, poul.steen
Details
comparison MSO 2010 and LibreOffice 6.3 Master (51.31 KB, image/png)
2019-05-13 15:28 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description poul.steen 2018-11-22 19:42:54 UTC
Created attachment 146921 [details]
This file demonstrates the lack of rendering a hyperlink correctly in LibreOffice Writer version 6.1.3.2.

In version 6.1.3.2, the control word sequence appears not to be recognized, while in version 5.3.7.2 it is correctly rendered.
Comment 1 Xisco Faulí 2018-11-22 22:27:15 UTC
Thanks for reporting the issue.

Regression introduced by:

author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>	2017-08-18 22:14:08 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-11-10 02:01:57 +0100
commit	eaa9cf6a3069fba3d82c046f0041bfb537d9e648 (patch)
tree	55806b023e2f7c380a877d0df6b0bd5bb53ad46e
parent	7f603dd111afcc30eec8bbec97efc16ad8b4c4d1 (diff)
tdf#43017: Support for DOCX hyperlinks character properties

Bisected with: bibisect-linux64-6.0

Adding Cc: to Vasily Melenchuk
Comment 2 Roman Kuznetsov 2018-12-03 08:21:29 UTC
in MS Word 2010 hyperlink looks as in LO 6.2 beta 1, it's just black without underline
Comment 3 Xisco Faulí 2019-05-13 15:28:35 UTC
Created attachment 151368 [details]
comparison MSO 2010 and LibreOffice 6.3 Master
Comment 4 Xisco Faulí 2019-05-13 15:29:18 UTC
(In reply to Roman Kuznetsov from comment #2)
> in MS Word 2010 hyperlink looks as in LO 6.2 beta 1, it's just black without
> underline

Yep, true!!
Closing as RESOLVED NOTABUG. See attached image