Bug 121648 - FILEOPEN: EMF+: Wrong displaying of string, drawed with DrawDriverString record
Summary: FILEOPEN: EMF+: Wrong displaying of string, drawed with DrawDriverString record
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:6.3.0 target:6.1.4 target:6.2.0.1
Keywords: bibisected, bisected, regression
: 82113 (view as bug list)
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2018-11-23 01:08 UTC by Xisco Faulí
Modified: 2019-01-09 13:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 6.2 Master (184.67 KB, image/png)
2018-11-23 01:08 UTC, Xisco Faulí
Details
EMF/EMF+ file extracted from file (103.76 KB, image/x-wmf)
2018-11-26 09:14 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-11-23 01:08:40 UTC
Created attachment 146930 [details]
Comparison MSO 2010 and LibreOffice 6.2 Master

Steps to reproduce:
1. Open attachment 78551 [details] from bug 63991

-> text is unreadable

Reproduced in

Version: 6.2.0.0.beta1+
Build ID: a5bb6a0406d0018d1df279b925c80b392d9db277
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-11-23 01:09:56 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cd7054b5e49f435349860d55bcff5a78d14a5f67

author	Bartosz Kosiorek <gang65@poczta.onet.pl>	2018-11-02 15:53:05 +0100
committer	Bartosz Kosiorek <gang65@poczta.onet.pl>	2018-11-05 19:28:22 +0100
commit	cd7054b5e49f435349860d55bcff5a78d14a5f67 (patch)
tree	3e07a4cf2894c09dfbe239493486c9e7763bbedc
parent	485efed71807ecee5ce69fa556db98dbc78a97e5 (diff)
tdf#55058 tdf#106084 tdf#114738 EMF+ Add rotation support for String drawing

Bisected with: bibisect-linux64-6.2

Adding Cc: to Bartosz Kosiorek
Comment 2 Bartosz 2018-11-26 09:14:11 UTC
Created attachment 147027 [details]
EMF/EMF+ file extracted from file
Comment 4 Commit Notification 2018-11-27 10:35:59 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f54c76e1ef8aa1e076ebbc0dbb356e87463557ed%5E%21

tdf#121648 EMF+ Fix displaying DrawDriverString record

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-11-27 10:46:26 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/babf033fddf1d1212a268703a7dcd96214560f26%5E%21

tdf#121648 EMF+ Fix displaying DrawDriverString record

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-11-28 08:12:02 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/0aabf27cd4a80cbea90fe61b4aa045b805f933ac%5E%21

tdf#121648 EMF+ Fix displaying DrawDriverString record

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-11-28 11:34:22 UTC
Verified in

Version: 6.1.0.0.alpha1+
Build ID: 3a801799536e6870f2fb111b1cc00b9575a35a39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Bartosz Kosiorek, thanks for fixing this!
Comment 8 Xisco Faulí 2018-11-28 11:42:01 UTC
I meant 

Version: 6.2.0.0.beta1+
Build ID: ce7bb69f8205bcbe36cba4c53bd110e07ef3e05d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Bartosz 2019-01-09 13:18:56 UTC
*** Bug 82113 has been marked as a duplicate of this bug. ***