Bug 121662 - FILEOPEN DOCX Line Numbers created with Word do not start with the same value
Summary: FILEOPEN DOCX Line Numbers created with Word do not start with the same value
Status: RESOLVED DUPLICATE of bug 121664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2018-11-23 10:01 UTC by NISZ LibreOffice Team
Modified: 2019-07-09 14:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer. (235.50 KB, image/png)
2018-11-23 10:01 UTC, NISZ LibreOffice Team
Details
Example file from Word (21.26 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-23 10:02 UTC, NISZ LibreOffice Team
Details
Screenshot of the original file in Writer 6.2.4 and 6.4alpha (156.13 KB, image/png)
2019-07-09 14:12 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-11-23 10:01:24 UTC
Description:
Line Numbers in DOCX documents created with Microsoft Word 2010 do not start with the same value when the document is opened in LibreOffice Writer.

Steps to Reproduce:
    1. Create a new document in Microsoft Word.
    2. Type “=lorem(25)” and press Enter
    3. On the Page Layout tab, in the Page Setup group, click Line Numbers.
    4. Select Line Numbering Options.
    5. Click Line Numbers on the Layout tab.
    6. Select the Add line numbering check box.
    7. Type 5 next to Start at and click OK.
    8. Click on OK button.
    9. Save the file as DOCX.
    10. Open the same file in LibreOffice Writer.
    11. Compare the original file opened in Word and Writer.

Actual Results:
Line numbers start at 4 when the document is opened in LibreOffice Writer.


Expected Results:
Line numbers should start at the same value as the original file when the document is opened in Microsoft Word 2010.



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-11-23 10:01:45 UTC
Created attachment 146952 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2018-11-23 10:02:02 UTC
Created attachment 146953 [details]
Example file from Word
Comment 3 Xisco Faulí 2018-11-26 17:41:58 UTC
Reproduced in

Version: 6.2.0.0.beta1+
Build ID: a63cd8bbe7cf881daa8dc7a7f32f3e5ac384e902
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default;

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

in previous versions, it starts from 0
Comment 4 RickyTzou 2018-11-29 08:27:12 UTC
Reproduced in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded.

Thank you!
Comment 5 Xisco Faulí 2018-11-29 09:37:16 UTC
Hi RickyTzou,
let change the version to the earliest version affected
Comment 6 Gabor Kelemen 2019-07-09 14:12:03 UTC
Created attachment 152687 [details]
Screenshot of the original file in Writer 6.2.4 and 6.4alpha

This seems to be solved in:

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 49422a469646ad8be43ba828ca24c2484c26b9e8
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-08_00:50:19
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 7 Gabor Kelemen 2019-07-09 14:14:30 UTC
I guess this has solved it in our other bug: 

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/46c5c62a9829a217f54d826c2cff6d2e15f7cba9%5E%21

Related: tdf#121664 DOCX filter: fix line numbering start value handling

It will be available in 6.3.0.

Thanks again Miklos :)

*** This bug has been marked as a duplicate of bug 121664 ***