Bug Hunting Session
Bug 121701 - Ability to selectively Pin document in front of other applications
Summary: Ability to selectively Pin document in front of other applications
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2018-11-25 07:03 UTC by 00
Modified: 2018-11-26 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
1 (101.09 KB, image/png)
2018-11-25 07:07 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2018-11-25 07:03:25 UTC
Description:
When you "match" the file, it is easy to compare the window to the top.

design:
◎, use the pattern of "nails".

Writer, Calc, Impress, Draw, Math, Base, all use this design.

This idea comes from the program on the website below.
http://www.skybn.com/window-always-on-top/


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2018-11-25 07:07:07 UTC
Created attachment 147014 [details]
1
Comment 2 V Stuart Foote 2018-11-25 16:29:19 UTC
Term is "Pin" not "nail".

To be effective, this would have to be implemented natively for each OS/DE and requiring management of client frame interaction with other clients.

We've rejected similar encroachment into areas of OS/DE control in interest of cross-platform consistency and support; e.g. bug 113388, bug 114687

IMHO => WF
Comment 3 00 2018-11-26 08:09:58 UTC
(In reply to V Stuart Foote from comment #2)


If the scope is only LibreOffice,
it should be OK,
Because it won't work on other programs,
Make an impact.

That is,
Change this function to
Only the window that opens LibreOffice,
Fixed at the "top level".

Because it is only useful for LibreOffice,
So where to change,
Just the window arrangement of LibreOffice.

If the user opens another program,
The location of the window,
The same will be in front of LibreOffice.
Comment 4 Heiko Tietze 2018-11-26 09:51:26 UTC
To keep an application always on top is a function of the window manager. And I bet there are solutions in case of Windows (or other DE that do not provide easy configuration).
Comment 5 00 2018-11-26 15:13:24 UTC
(In reply to Heiko Tietze from comment #4)


The premise is that
Users should know that there is such a function.
You can also find this program.

This is why,
I want to add this feature to LibreOffice.