Bug Hunting Session
Bug 121702 - Added the GUI control for "Draw object height", "Draw object width", and "Draw object rotation degree" to the "Drawing Object properties" toolbar
Summary: Added the GUI control for "Draw object height", "Draw object width", and "Dra...
Status: RESOLVED DUPLICATE of bug 121492
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-25 07:30 UTC by 00
Modified: 2018-11-26 09:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
1 (172.84 KB, image/png)
2018-11-25 07:44 UTC, 00
Details
2 (119.06 KB, image/png)
2018-11-25 07:44 UTC, 00
Details
3 (145.25 KB, image/png)
2018-11-25 07:45 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2018-11-25 07:30:22 UTC
Description:
When drawing a picture, the function of "pattern height", "pattern width", and "pattern rotation degree" is often used.

So put these functions on the "toolbar", "direct input of numbers", "look directly at the number", it will be done very quickly (because you don't have to open the window separately, it will do very quickly.).

Writer, Calc, Impress, Draw, Math, Base, all use this design.

Note:
1. The "toolbar" of Word already has the function of "pattern height" and "pattern width".


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2018-11-25 07:44:12 UTC
Created attachment 147015 [details]
1
Comment 2 00 2018-11-25 07:44:50 UTC
Created attachment 147016 [details]
2
Comment 3 00 2018-11-25 07:45:23 UTC
Created attachment 147017 [details]
3
Comment 4 V Stuart Foote 2018-11-25 15:37:56 UTC
Another "enhancement" lost in translation. Not "Pattern", rather "Shape" from MS Word. And in LibreOffice affecting a "Draw object". The associated Toolbar in LibreOffice would be the "Drawing Object Properties".

Persently we group the controls for Draw objects into a "Position and Size" dialog, its launch button accessible from the context menu for a draw object when selected.

Trivial to add that button to the Draw Object Properties toolbar for convenient launching of the dialog.

Not at all clear there is benefit to consuming the toolbar space of adding the spinner widgets to the toolbar.

IMHO a clear WF of adding the spinners, but would agree to adding the dialog button to the toolbar.
Comment 5 00 2018-11-26 07:20:18 UTC
(In reply to V Stuart Foote from comment #4)


It cannot be added because Word does not have the function of "pattern rotation degree".
In fact, Word missed the "pattern rotation degree" function.

Users who are often drawing pictures often use the function of "pattern rotation degree".
Because I used the function of "pattern rotation degree".

You can "enter the number directly", "see the number directly", it will become very convenient.

Remember, the function is not too much.
Comment 6 Heiko Tietze 2018-11-26 09:55:08 UTC
Same request done in bug 121492 (UNO commands are the technical basis for UI modifications).

*** This bug has been marked as a duplicate of bug 121492 ***