Download it now!
Bug 121747 - Tabbed: Add 'Show Glue Points Functions" to Home and View tab in Draw
Summary: Tabbed: Add 'Show Glue Points Functions" to Home and View tab in Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2018-11-28 03:40 UTC by Rizal Muttaqin
Modified: 2020-07-14 23:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-11-28 03:40:08 UTC
Description:
NB Tabbed: Add "Show Glue Points Functions" to Home and View tabs in Draw.

When working with flowchart, there's no "Show Glue Points Functions" icon in Tabbed interface. I have to enable it from hamburger menu > Toolbars > Glue Points. It made loss productivity

Steps to Reproduce:
1. Enable Tabbed NB interface in Draw
2. Add two shapes and join them with connector line
3.

Actual Results:
There is no Show Glue Points Functions on Tabbed NB in Draw when I want to view glue point 
Expected Results:
There is Show Glue Points Functions on Tabbed NB in Draw when I want to view glue point 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Durgapriyanka 2018-11-28 16:25:59 UTC
Cannot reproduce in 

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 2 Rizal Muttaqin 2018-11-29 04:03:46 UTC
(In reply to Durgapriyanka from comment #1)
> Cannot reproduce in 
> 
> Version: 6.0.6.2
> Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
> CPU threads: 2; OS: Windows 6.1; UI render: default; 
> Locale: en-US (en_US); Calc: group

This bug affect 6.2.x and 6.3.x, Draw in 6.0.x not yet have Tabbed interface
Comment 3 Rizal Muttaqin 2018-11-29 04:05:25 UTC
The "Insert Glue Point" function in Home tab does not work. It would be better this button replaced by "Show Glue Points Functions" instead.
Comment 4 Commit Notification 2018-11-29 19:42:40 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5f2e74b8a3fdf4b224520aa930273e2c6bd2cda9%5E%21

tdf#121747 NB tabbed: add glue point group to view tab

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-11-30 08:14:05 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d2e5e266c15f72570708980dfbd0d3460996a01a%5E%21

tdf#121747 NB tabbed: add glue point group to view tab

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.