Bug 121750 - Once the comment is entered, I couldn't show it by hovering with the > mouse over the little red square
Summary: Once the comment is entered, I couldn't show it by hovering with the > mouse ...
Status: RESOLVED DUPLICATE of bug 120797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-11-28 06:56 UTC by Dan Dascalescu
Modified: 2019-03-28 17:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Inserting a comment in Calc v6.2 (427.46 KB, image/gif)
2018-11-28 06:56 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2018-11-28 06:56:22 UTC
Created attachment 147083 [details]
Inserting a comment in Calc v6.2

Inserting a comment in Calc v6.2 is a frustrating experience:

1. I can't seem to be able to drag the comment box handles to enlarge it (this is perfectly possible in Excel)

2. Typing a longer comment results in the comment overlapping the cells below.

3. Once the comment is entered, I couldn't show it by hovering with the mouse over the little red square in the top right corner of the cell.

Please see the attached screencast.
Comment 1 Xisco Faulí 2018-11-28 10:57:54 UTC
Thanks for reporting this issue.
Seems like a dupe of bug 114956

*** This bug has been marked as a duplicate of bug 114956 ***
Comment 2 Dan Dascalescu 2018-11-29 18:27:12 UTC
Thanks for pointing me to the dupe for #2.

#1 and #3 still stand separately though - maybe we can reduce the scope of this bug to that?

1. Can't drag the comment box handles to enlarge it

3. Once the comment is entered, I couldn't show it by hovering with the mouse over the little red square in the top right corner of the cell.
Comment 3 Xisco Faulí 2018-12-03 13:22:30 UTC
Ok. Changing it back to UNCONFIRMED until a third person can confirm it...
Comment 4 Durgapriyanka 2018-12-05 18:22:45 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded

However, Mouse hovering works, so that my comments are seen when I hover the pointer on the little red square on the top right corner of the cell.

The first two points that you mentioned did not work in this version too.
Comment 5 raal 2018-12-30 15:25:30 UTC
(In reply to Dan Dascalescu from comment #2)
> Thanks for pointing me to the dupe for #2.
> 
> #1 and #3 still stand separately though - maybe we can reduce the scope of
> this bug to that?
> 
> 1. Can't drag the comment box handles to enlarge it

Duplicate of bug 68695

> 
> 3. Once the comment is entered, I couldn't show it by hovering with the
> mouse over the little red square in the top right corner of the cell.

Confirm with Version: 6.3.0.0.alpha0+
Build ID: 993913469e74e9db9743004bbe36aa412411671c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Regression
Comment 6 raal 2018-12-30 17:55:43 UTC
> > 
> > 3. Once the comment is entered, I couldn't show it by hovering with the
> > mouse over the little red square in the top right corner of the cell.
> 

This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks

7ee4f79e6b2d49fd32c27bb97917aa236509f527 is the first bad commit
commit 7ee4f79e6b2d49fd32c27bb97917aa236509f527
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Sep 13 09:34:16 2018 +0200

    source sha:7034311dce663c895577267110baadbec312d491

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-06 18:15:02 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-13 08:49:35 +0200
commit	7034311dce663c895577267110baadbec312d491 (patch)
tree	8c1d712cbfb1b15dc492e6e724b6b22892914249
parent	d92b0efe58b77247e1e5292c1a989baa934df797 (diff)
Support buffering SystemDependent GraphicData (II)
Comment 7 Xisco Faulí 2019-03-28 17:37:56 UTC
Regression introduced by
https://cgit.freedesktop.org/libreoffice/core/commit/?id=7034311dce663c895577267110baadbec312d491
Dupe of 120797

*** This bug has been marked as a duplicate of bug 120797 ***