Bug 121759 - Doesn't active menu item Insert->Headers and Footers in Calc 6.2
Summary: Doesn't active menu item Insert->Headers and Footers in Calc 6.2
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks:
 
Reported: 2018-11-28 14:16 UTC by Roman Kuznetsov
Modified: 2019-01-01 18:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-11-28 14:16:48 UTC
Description:
Doesn't active menu item Insert->Headers and Footers in Calc 6.2
After fix bug 99296 we can't insert header or footer uses menu Insert. Menu item doesn't active. But if in dialogue Format->Page on tab Header (or Footer) you check option "Header (or Footer) on", then menu item Insert->Headers and Footers will became active and it works as should.

Steps to Reproduce:
1. try insert header or footer uses Insert->Headers and Footers
2.
3.

Actual Results:
Doesn't active menu item Insert->Headers and Footers

Expected Results:
Item Insert->Headers and Footers is active and works as should


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Timur 2018-11-28 15:24:11 UTC
Unless I miss something obvious, I reproduce and confirm this.
Comment 2 Heiko Tietze 2018-11-28 15:37:03 UTC
Cannot confirm. If "[x] Use Header/Footer menu" is enabled you have the "advanced" blue context menu. In all case you can click Insert > Header and Footer > Header > Default Style or go via the page dialog to enter a header (same for footer).

Version: 6.3.0.0.alpha0+
Build ID: 022ef7c579d09b9e57bf0fffba466cd385c73c52
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xavier Van Wijmeersch 2018-11-28 20:32:52 UTC
in calc header/footer its gray out
in writer you can enable use header/footer menu but not in calc

Version: 6.3.0.0.alpha0+
Build ID: 75dd5d2e734ad9e8265b1954c7496d1ba241079e
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Roman Kuznetsov 2018-11-29 10:51:02 UTC
(In reply to Heiko Tietze from comment #2)
> Cannot confirm. If "[x] Use Header/Footer menu" is enabled you have the
> "advanced" blue context menu. In all case you can click Insert > Header and
> Footer > Header > Default Style or go via the page dialog to enter a header
> (same for footer).
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 022ef7c579d09b9e57bf0fffba466cd385c73c52
> CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> Calc: threaded

Heiko, I say about >>>Calc<<< header/footer. 
You wrote about Writer header/footer
Comment 5 Heiko Tietze 2018-11-29 12:06:00 UTC
Yes, bug 99296 changed this. When you enable Header or Footer for the page you get the menu item back. This is a consequence of the change and not a regression. So => NAB. 

Or do you have a different opinion, Samuel, as requester on the other ticket?
Comment 6 Samuel Mehrbrodt (CIB) 2018-11-29 12:09:16 UTC
(In reply to Heiko Tietze from comment #5)
> Yes, bug 99296 changed this. When you enable Header or Footer for the page
> you get the menu item back. This is a consequence of the change and not a
> regression. So => NAB. 
> 
> Or do you have a different opinion, Samuel, as requester on the other ticket?

Yes this was the reason I didn't just disable the headers and footers in bug 99296. Needs some serious UX improvements before we can do that.
This is not at all clear to people as you can see with this bug.
Comment 7 Heiko Tietze 2018-11-29 12:14:12 UTC
We could move the menu entry to Edit, where it is actually better suited anyway. By doing so it's more clear that no header/footer has been enabled to be edited.
Comment 8 Roman Kuznetsov 2018-11-29 12:29:12 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #6)
> (In reply to Heiko Tietze from comment #5)
> > Yes, bug 99296 changed this. When you enable Header or Footer for the page
> > you get the menu item back. This is a consequence of the change and not a
> > regression. So => NAB. 
> > 
> > Or do you have a different opinion, Samuel, as requester on the other ticket?
> 
> Yes this was the reason I didn't just disable the headers and footers in bug
> 99296. Needs some serious UX improvements before we can do that.
> This is not at all clear to people as you can see with this bug.

I offer from menu Insert->Headers and Footers in Calc 6.2 open dialogue "Page Style" on tab Header to user can make active header himself or can select tab Footer and make active it
Comment 9 Heiko Tietze 2018-11-29 12:55:30 UTC
(In reply to Roman Kuznetsov from comment #8)
> I offer from menu Insert->Headers and Footers in Calc 6.2 open dialogue
> "Page Style" on tab Header to user can make active header himself or can
> select tab Footer and make active it

That doesn't work. The Page dialog is one part and the other is the (Edit) Header and Footer dialog. We need two different commands, going to Page from Insert > H&F when there is no H|F set and to another dialog if it's set would be bad usability (and not easy to do).
Comment 10 Samuel Mehrbrodt (CIB) 2018-11-30 07:10:24 UTC
(In reply to Heiko Tietze from comment #7)
> We could move the menu entry to Edit, where it is actually better suited
> anyway. By doing so it's more clear that no header/footer has been enabled
> to be edited.

How does the user know where he enables the header and footer? This needs to be integrated into the header/footer dialog somehow before we disable them by default.
Comment 11 Heiko Tietze 2018-11-30 07:34:57 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> (In reply to Heiko Tietze from comment #7)
> > We could move the menu entry to Edit, where it is actually better suited
> > anyway. By doing so it's more clear that no header/footer has been enabled
> > to be edited.
> 
> How does the user know where he enables the header and footer? This needs to
> be integrated into the header/footer dialog somehow before we disable them
> by default.

Added the UX list, and to summarize the issue is about a disabled menu entry in Calc after switching off Header/Footer by default at the page dialog.

Actually I don't see this as a big issue. It was the same before with the little difference that the user switched H/F off manually. Okay, it's a big difference. But still, it's more or less the same in all other modules where you first have to enable H/F. By moving the disabled option to the Edit menu it becomes more clear that this dialog does not Insert.

The alternative is somewhat like kompilainenn suggested in bug 121777 and I doubt it's easier to understand. 

Unfortunately the topic is urgent as the patch went into 6.2.
Comment 12 Cor Nouws 2018-12-04 19:58:14 UTC
(In reply to Heiko Tietze from comment #5)
> Yes, bug 99296 changed this. When you enable Header or Footer for the page
> you get the menu item back.
And then the Edit header/footer dialog opens (there is some default content).
In Writer the item is active from scratch. So why not in Calc?
Comment 13 Heiko Tietze 2018-12-05 07:24:55 UTC
(In reply to Cor Nouws from comment #12)
> In Writer the item is active from scratch. So why not in Calc?

It was requested in bug 99296 to disable h/f in Calc, and you also have to enable it first in Writer. But that's not an answer or solution to this issue.

a) Revert 99296
b) Make this a WFM
c) Move the disabled menu item to Edit
d) Auto enable H/F when content is inserted at the edit dialog
Comment 14 Roman Kuznetsov 2018-12-05 10:31:09 UTC
(In reply to Heiko Tietze from comment #13)
> (In reply to Cor Nouws from comment #12)
> > In Writer the item is active from scratch. So why not in Calc?
> 
> It was requested in bug 99296 to disable h/f in Calc, and you also have to
> enable it first in Writer. But that's not an answer or solution to this
> issue.
 
My opinions:

 a) Revert 99296 - NO
 b) Make this a WFM - no
 c) Move the disabled menu item to Edit - may be yes
 d) Auto enable H/F when content is inserted at the edit dialog - no

May be just delete this menu item from Insert and change Help that user knows hot to enable header/footer in Calc (from menu Format->Page)?
Comment 15 Alex Thurgood 2018-12-06 14:52:00 UTC
IMHO, if the menu isn't active until H/F is switched on in Format > Page, then I see little sense or logic, from a UX perspective, of having such a menu as an entry in the Insert main menu.

What is the aim of this functionality ? If, as I understand from Heiko's comments, it is to edit the H/F content, then put it under the Edit menu. If it doesn't work as designed, why do we have it at all ?
Comment 16 Heiko Tietze 2018-12-06 16:00:41 UTC
Samuel set my patch to -1 with this argument: "As discussed on the mailing list, I see a fundamental problem and this doesn't make it much clearer."

So we can either revert the other patch or do nothing, ie. WFM this issue.
Comment 17 Samuel Mehrbrodt (CIB) 2018-12-06 16:02:36 UTC
(In reply to Heiko Tietze from comment #16)
> Samuel set my patch to -1 with this argument: "As discussed on the mailing
> list, I see a fundamental problem and this doesn't make it much clearer."
> 
> So we can either revert the other patch or do nothing, ie. WFM this issue.

Please see the discussion on the ML for other options. Also I'm not blocking on the patch, I just say I don't like it for the reasons written on the dev mailing list.
Comment 18 Heiko Tietze 2018-12-06 16:14:29 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #17)
> Please see the discussion on the ML for other options. Also I'm not blocking
> on the patch, I just say I don't like it for the reasons written on the dev
> mailing list.

Your opinion in c6 stands against 2x for changing the menu. Besides -1 being a blocker, I will revert the other patch as you were the reporter on it and there haven't been any complains by other users. Though, there was some agreement on the change as here on moving the entry.
Comment 19 Commit Notification 2018-12-07 07:41:37 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d08e63fb1ab16d96e3d1404c4b82267447104a0f%5E%21

tdf#121759 Revert "tdf#99296 - Disable headers/footers by default"

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2018-12-07 19:30:16 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1d3a07415eda3014d67d7c56466a8ad1d0ec51d9%5E%21

tdf#121759 Revert "tdf#99296 - Disable headers/footers by default"

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.