Bug 121800 - Missing images, formatting from Microsoft Publisher 2013 imported document
Summary: Missing images, formatting from Microsoft Publisher 2013 imported document
Status: RESOLVED DUPLICATE of bug 130479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://github.com/pmartinolli/TM-Sch...
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Regressions-imageHandling
  Show dependency treegraph
 
Reported: 2018-11-29 14:05 UTC by Fabian Rodriguez
Modified: 2020-05-21 05:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Render of MS Pub 2013 document missing formatting and images (108.28 KB, image/png)
2018-11-29 14:06 UTC, Fabian Rodriguez
Details
Original view (PDF) (446.38 KB, application/pdf)
2018-11-30 07:54 UTC, Roman Kuznetsov
Details
Original PUB file (452.00 KB, application/vnd.ms-publisher)
2018-11-30 07:55 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Rodriguez 2018-11-29 14:05:08 UTC
Description:
When importing an MS Publisher 2013 document, all images and some formatting is missing.

The end result should be this:

https://github.com/pmartinolli/TM-SchoProMa/blob/master/TM-SchoProMa-v1.3.pdf

The source file is here:

https://github.com/pmartinolli/TM-SchoProMa/blob/master/TM-SchoProMa-v1.3.pub

Steps to Reproduce:
1. Open the .pub file using LibreOffice Draw


Actual Results:
All images and some formatting is missing.

Expected Results:
Render as attached example (output.png)


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Fabian Rodriguez 2018-11-29 14:06:35 UTC
Created attachment 147144 [details]
Render of MS Pub 2013 document missing formatting and images

LibreOffice Draw Version: 6.1.3.2
Build ID: 1:6.1.3-1
Comment 2 Fabian Rodriguez 2018-11-29 14:14:44 UTC
Added tags, URL.
Comment 3 Durgapriyanka 2018-11-29 22:37:17 UTC
Thank you for reporting the bug. I can not reproduce the bug in

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 4 Roman Kuznetsov 2018-11-30 07:54:06 UTC
Created attachment 147163 [details]
Original view (PDF)
Comment 5 Roman Kuznetsov 2018-11-30 07:55:04 UTC
Created attachment 147164 [details]
Original PUB file
Comment 6 Roman Kuznetsov 2018-11-30 07:59:14 UTC
repro in

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded

and in

Version: 6.3.0.0.alpha0+
Build ID: f21d2b48bd68424a96aa6cd5572e368208378291
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-11-27_00:26:54
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 7 Xisco FaulĂ­ 2018-12-05 15:30:04 UTC
Regression introduced by 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e02efb621fe672aa52e56caa916cf5c3fd0a9cb8, which is the same as in bug 120871
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 120871 ***
Comment 8 Aron Budea 2020-05-21 05:38:41 UTC

*** This bug has been marked as a duplicate of bug 130479 ***