Bug Hunting Session
Bug 121810 - Crash in: libgobject-2.0.so.0.5600.3 when selecting more on error dialog
Summary: Crash in: libgobject-2.0.so.0.5600.3 when selecting more on error dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0.1 target:6.3.0
Keywords: bibisected, bisected, regression
: 121965 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-29 21:44 UTC by Drew Jensen
Modified: 2018-12-07 20:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["libgobject-2.0.so.0.5600.3"]


Attachments
test file for crash (11.99 KB, application/vnd.oasis.opendocument.database)
2018-11-29 21:44 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-11-29 21:44:43 UTC
Created attachment 147157 [details]
test file for crash

This bug was filed from the crash reporting server and is br-a88a20cc-0950-4902-8174-08de3b3b8d64.
=========================================

The test system is Ubuntu 18.04.
There is no crash with Version: 6.2.0.0.beta1 (From last Monday)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18


Does crash consistently with Version: 6.2.0.0.beta1+ (27 Nov)
Build ID: 6ab7bfbca4148416233dbf8b9bfc79f3a1dfa821

To reproduce:

1 - download the attached odb file.
2 - Open in Base and start the mirgation assistant
3 - When the error box displays click on 'More'
Crash
Comment 1 MM 2018-11-30 12:43:12 UTC
Confirmed on mint 18.3 x64 with Version: 6.3.0.0.alpha0+
Build ID: d8d231f97d829350d965105e3a5be119d1a6494c
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-30_00:14:18
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Unconfirmed on mint 18.3 x64 with Version: 6.3.0.0.alpha0+
Build ID: 8a02a1d329c43df6de383a7b0cf8ac14247b18c9
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-17_20:48:16
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Drew Jensen 2018-11-30 14:17:09 UTC
Changed summary.

The crash happens when ever an error box is displayed by Base and the user has the option to click on 'More' details. 

The SDBC driver is not relevant, nor is the Firebird Migration Assistant. Tweaking a query def in a HSQL database to generate an SQL error will lead to the same crash.

ps - still not able to bisect this at the moment. Perhaps someone else has their repos setup properly today, so adding the keyword bibisectrequest also.
Comment 3 raal 2018-12-01 16:46:06 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

9f8daa91b1d102bb6445df46e0e011f4c1507b62 is the first bad commit
commit 9f8daa91b1d102bb6445df46e0e011f4c1507b62
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Nov 22 10:56:52 2018 +0100

    source sha:4b7cbb569e52e483a5edda8afe27d423e428edbb

author	Caolán McNamara <caolanm@redhat.com>	2018-11-17 21:37:50 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-22 09:55:16 +0100
commit	4b7cbb569e52e483a5edda8afe27d423e428edbb (patch)
tree	b767f526b821002d1b71d49e0e205d9e3dcab8fa
parent	b9b62d96f6de8908ddf69f5b56eb58fe82013a24 (diff)
weld SwCondCollPage
Comment 4 Commit Notification 2018-12-02 10:09:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d489e5fec01c1ae40713b1184042716f3d6ce988%5E%21

Related: tdf#121810 pass suitable message dialog parent around

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-12-02 10:10:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e84d236a81af429e92f3da39a83cca02da8fe3aa%5E%21

Related: tdf#121810 pass suitable message dialog parent around

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-12-02 10:11:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cd2ed4a079a5da676b836dd9dd5b00cf99c68ef2%5E%21

Resolves: tdf#121810 wrong column order

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-02 23:43:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3abcd34f37b6aba5025631c64a49d4c8c34effd2%5E%21

Resolves: tdf#121810 wrong column order

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-12-03 11:57:09 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 1ee8d4f63adf3113a4733a479c8faf9eb65f7b8d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for the quick fix!
Comment 9 Drew Jensen 2018-12-07 20:25:11 UTC
*** Bug 121965 has been marked as a duplicate of this bug. ***