Bug 121825 - Add date-related formulas for Writer tables
Summary: Add date-related formulas for Writer tables
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Formulas
  Show dependency treegraph
 
Reported: 2018-11-30 15:47 UTC by mathieu_pape
Modified: 2019-09-03 08:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mathieu_pape 2018-11-30 15:47:08 UTC
In Writer I would like to calculate the last day of the current month. I used something that works perfectly in Calc, being:

=EOMONTH(TODAY();0)

This gives me a number and with the cell formatted as a date it shows the wanted result : 30/11/18 in this case.

However, I use the exact same formula in Writer it gives back an error " * Expression is faulty * "

It would make sense to be able to work with dates in a software designed to write letters (among others of course)
Comment 1 Xavier Van Wijmeersch 2018-11-30 20:16:26 UTC
In writer you can use insert field, there you can select a fixed date or you can look in the 'More Fields' dialog
There you can choose a fixed date or 'daily' date (idem as today() in calc)

No need for a formula

If your not agree with the WFM solution then you can reopen as unconfirmed

Best regards
Comment 2 mathieu_pape 2018-12-01 16:25:01 UTC
Sorry, but TODAY() is definitely not the same as EOMONTH(TODAY();0), is it? With the field option, I would need to write the document on the last day of the month for instance to get the wanted date. And if I want to use EOMONTH(TODAY();6), I would have to write it in 6 months.
Comment 3 Xisco Faulí 2019-06-27 17:03:44 UTC
Tables in writer only contain a few formulas, for more advanced formulas you should use Calc. Later, you can embedded the document in the writer document.
Closing as RESOLVED WONTFIX
Comment 4 Roman Kuznetsov 2019-06-27 17:06:43 UTC
(In reply to Xisco Faulí from comment #3)
> Tables in writer only contain a few formulas, for more advanced formulas you
> should use Calc. Later, you can embedded the document in the writer document.
> Closing as RESOLVED WONTFIX

Xisco, it's an enhancement. I suggest to reopen it
Comment 5 Xisco Faulí 2019-06-27 17:13:40 UTC
(In reply to Roman Kuznetsov from comment #4)
> (In reply to Xisco Faulí from comment #3)
> > Tables in writer only contain a few formulas, for more advanced formulas you
> > should use Calc. Later, you can embedded the document in the writer document.
> > Closing as RESOLVED WONTFIX
> 
> Xisco, it's an enhancement. I suggest to reopen it

I know it's an enhancement, the problem is if we add support for this formula in writer, others might want to have other formulas supported as well, and in the end, we add support for all of them in Writer, which is not what Writer is aimed for... My take, WONTFIX
Comment 6 Xisco Faulí 2019-09-03 08:06:04 UTC
(In reply to Xisco Faulí from comment #5)
> (In reply to Roman Kuznetsov from comment #4)
> > (In reply to Xisco Faulí from comment #3)
> > > Tables in writer only contain a few formulas, for more advanced formulas you
> > > should use Calc. Later, you can embedded the document in the writer document.
> > > Closing as RESOLVED WONTFIX
> > 
> > Xisco, it's an enhancement. I suggest to reopen it
> 
> I know it's an enhancement, the problem is if we add support for this
> formula in writer, others might want to have other formulas supported as
> well, and in the end, we add support for all of them in Writer, which is not
> what Writer is aimed for... My take, WONTFIX

No further comments written.
Closing as RESOLVED WONTFIX