Bug 121833 - Low raster quality when using "compress" on SVG inside Writer
Summary: Low raster quality when using "compress" on SVG inside Writer
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: Image-Compression
  Show dependency treegraph
 
Reported: 2018-11-30 19:59 UTC by Tobias Wendorff
Modified: 2019-10-15 02:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Wendorff 2018-11-30 19:59:42 UTC
Description:
When using "compress" (see steps below) to convert a SVG to raster, all settings for resolutions get ignored. Seems like it's hardcoded to 96 ppi.

This might be related to #121831

Steps to Reproduce:
1. Download a reference SVG: https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/
2. Insert it into a Write document
3. Right click on the SVG
4. Select a high resolution, like 300 ppi

Actual Results:
Unsharp raster image.

Expected Results:
It's expected to have the SVG rasterized at the dimension and resolutions set.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The problem occurs on all versions, which can read and display SVG files. Ghostscript, imagemagick and pstoedit have been installed and are reachable via path variable.

This might be related to #121831
Comment 1 Xisco Faulí 2019-01-14 17:02:11 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 QA Administrators 2019-09-14 02:48:16 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2019-10-15 02:30:00 UTC
Dear Tobias Wendorff,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp