Bug 121840 - Libreoffice Crashes on opening simple Calc spreadsheet from iCloud
Summary: Libreoffice Crashes on opening simple Calc spreadsheet from iCloud
Status: RESOLVED DUPLICATE of bug 121778
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Mac OS X (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 121901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-01 12:17 UTC by Charles
Modified: 2018-12-04 15:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example spreadsheet doc (7.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-12-03 16:58 UTC, Michael Plehnert
Details
screenshot TrubleDoc.ods (73.80 KB, image/png)
2018-12-03 17:01 UTC, Michael Plehnert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2018-12-01 12:17:02 UTC
Description:
Libreoffice Crashes on opening Calc spreadsheet: Using macOs Mojave and latest version of Libreoffice. See details below

 Version: 6.1.3.3
Build ID: 502e2001d4af96907b8ef3a795b2d9230cf93f0e
CPU threads: 4; OS: Mac OS X 10.14.1;

Steps to Reproduce:
1. I Opened a saved calc spreadsheet from iCloud, as soon as it opens then Libreoffice closes immediately. This happens on on two different Apple computers. 
2.
3.

Actual Results:
See above

Expected Results:
Nothing


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Text documents open ok
Comment 1 raal 2018-12-01 15:10:46 UTC Comment hidden (obsolete)
Comment 2 Michael Plehnert 2018-12-03 16:58:50 UTC
Created attachment 147246 [details]
example spreadsheet doc
Comment 3 Michael Plehnert 2018-12-03 17:01:21 UTC
Created attachment 147247 [details]
screenshot TrubleDoc.ods

I've got the same problem, see files attached.
Comment 4 raal 2018-12-04 13:02:49 UTC
Confirmed in comment 2
Comment 5 raal 2018-12-04 13:28:45 UTC
Info from reporter: Libreoffice calc, worked perfectly until the Nov 28th Update - See below for “About details”  -  I have two Apple computers an iMac and a MacBook pro. Calc crashes out on both of them.

Version: 6.1.3.3
Build ID: 502e2001d4af96907b8ef3a795b2d9230cf93f0e
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded

marking as regression.
Comment 6 Alex Thurgood 2018-12-04 15:34:21 UTC
*** Bug 121901 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2018-12-04 15:42:07 UTC

*** This bug has been marked as a duplicate of bug 121778 ***