Download it now!
Bug 121855 - Calc freezes (CPU power 100% and No response) with fcitx and VCL gtk3
Summary: Calc freezes (CPU power 100% and No response) with fcitx and VCL gtk3
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords:
: 106272 121595 121981 (view as bug list)
Depends on:
Blocks: CJK GTK3 CPU-AT-100%
  Show dependency treegraph
 
Reported: 2018-12-02 04:06 UTC by nogajun
Modified: 2019-03-04 21:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nogajun 2018-12-02 04:06:19 UTC
Description:
Calc become unresponsive(CPU power 100%), After "Freeze Cells", input the "=" to move the active cell.

Steps to Reproduce:
Environment
- Input method: fcitx
- VCL: gtk3

1. Launch the Calc (with SAL_USE_VCLPLUGIN=gtk3)

    $ SAL_USE_VCLPLUGIN=gtk3 /opt/libreofficedev6.2/program/soffice --calc

2. Select menu View > Freeze Cells > Freeze First Row on A1 cell.
3. Input the "=" (Equal)
4. Press the Down key

Actual Results:
No responsive and CPU power 100%

Expected Results:
The Active cell moves.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
ibus is no problem, VCL gen and kde5 is no proble.

LibreOffice:
バージョン: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS:Linux 4.18; UI render: default; VCL: gtk3; 
ロケール: ja-JP (ja_JP.UTF-8); UIの言語: ja-JP
Calc: threaded

Operating System: Debian GNU/Linux sid
KDE Plasma Version: 5.14.3
Qt Version: 5.11.2
KDE Frameworks Version: 5.51.0

Input method:
fcitx: 1:4.2.9.6-5
fcitx-mozc: 2.23.2815.102+dfsg-2+b1
fcitx-hangul: 0.3.1-2
Comment 1 Kevin Suo 2018-12-02 09:15:38 UTC
Not sure whether it is a duplicate of bug 106272, but quite similar.
Comment 2 Franklin Weng 2018-12-02 09:30:03 UTC
Reproduced in Kubuntu 18.04 with fcitx.

版本:6.2.0.0.beta1+
組建 ID:6ab7bfbca4148416233dbf8b9bfc79f3a1dfa821
CPU 執行緒:2; OS:Linux 4.15; UI 算繪:預設; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-11-27_19:54:44
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded

Kubuntu 18.04 with other input method engine (my case "gcin") would not reproduce this problem.
Comment 3 Caolán McNamara 2018-12-04 12:34:06 UTC
the IM looks for surrounding_text, the a11y apis are used to try and find the widget which has focus, ends up searching the spreadsheet grid for the cell, the virtual grid is immense so its searches for years
Comment 4 Caolán McNamara 2018-12-04 13:01:01 UTC
bug 56937, bug 96685, bug 100903 and bug 106133 are related to this class of problem
Comment 5 Caolán McNamara 2018-12-04 13:07:12 UTC
*** Bug 106272 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2018-12-04 16:49:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f62a0d9fbc4e67de134e4166410f3b63ea442993%5E%21

tdf#121855 like osx case don't search near-infinite calc grid for focus

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-04 19:58:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cd0c794a6cfaf9c008682596d2cdae6aa57c8bbf%5E%21

tdf#121855 like osx case don't search near-infinite calc grid for focus

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-01-01 21:52:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/78c52b1ab97397f99af279df78df798efde91136%5E%21

tdf#121855 like osx case don't search near-infinite calc grid for focus

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2019-01-07 10:28:18 UTC
*** Bug 121981 has been marked as a duplicate of this bug. ***
Comment 10 Caolán McNamara 2019-03-04 12:18:36 UTC
*** Bug 121595 has been marked as a duplicate of this bug. ***