Download it now!
Bug 121862 - Edit style in table does nothing
Summary: Edit style in table does nothing
Status: RESOLVED DUPLICATE of bug 57344
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-02 13:42 UTC by Andreas
Modified: 2019-12-03 20:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
video showing the issue (1.23 MB, video/mp4)
2018-12-02 13:42 UTC, Andreas
Details
document that has the issue (189.59 KB, application/vnd.oasis.opendocument.presentation)
2018-12-02 13:43 UTC, Andreas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2018-12-02 13:42:30 UTC
Description:
I created a table, perform right click > Edit style...

Actual Result: Nothing happens. Only thing is that I cannot use left click anymore. Right click works.

Expected result: A window should open to edit the style (I think)

---
I will attach a video and document with the issue

Steps to Reproduce:
1. Create a table
2. Right click > Edit style

Actual Results:
Nothing happens

Expected Results:
A window opens to edit the style


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Andreas 2018-12-02 13:42:56 UTC
Created attachment 147224 [details]
video showing the issue
Comment 2 Andreas 2018-12-02 13:43:55 UTC
Created attachment 147225 [details]
document that has the issue
Comment 3 Durgapriyanka 2018-12-02 14:33:37 UTC
Thank you for reporting the bug. I can not reproduce the bug in 

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group

A window opens to edit the style.
Comment 4 Andreas 2018-12-02 16:35:42 UTC
Interesting. I have the issue on Kubuntu 18.04.
Does the window contain some unusual controls, which could require some OpenGL stuff or libs, that I don't have?
Comment 5 Andreas 2018-12-02 16:47:21 UTC
Is there a way to provide a log or some more information to tackle the issue?
Comment 6 Andreas 2018-12-02 22:42:49 UTC
I just noticed that the issue does not occur when the file is saved as pptx (PowerPoint 2007-2019). Further the issue only occurs when performing "Edit style..." on a table. For text etc. it works as expected.

Please check the odp file that I attached. In this document, the issue occurs.

Anyway the dialog that opens seems to be unimportant anyway. I thought one could change the overall table style with this dialog, but I was wrong.
Comment 7 Durgapriyanka 2018-12-03 15:45:19 UTC
Hello, Thank you for your comments.

I did check it again and I can confirm that the bug is present in the document which you have attached, also it hangs there.

However, when I did it yesterday it was working fine and also if I create a table myself and edit it in impress, a window for edit style opens.
Comment 8 Buovjaga 2018-12-04 13:10:59 UTC

*** This bug has been marked as a duplicate of bug 90018 ***
Comment 9 Timur 2019-12-03 20:48:28 UTC

*** This bug has been marked as a duplicate of bug 57344 ***