Bug 121868 - Hangs up when scrolling after upgrading to version 6.1.3
Summary: Hangs up when scrolling after upgrading to version 6.1.3
Status: RESOLVED DUPLICATE of bug 121778
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-02 18:34 UTC by RuslanVa
Modified: 2018-12-20 08:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
two cursors (1.27 MB, image/png)
2018-12-05 16:55 UTC, RuslanVa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RuslanVa 2018-12-02 18:34:13 UTC
Description:
After the update, Calc on MacMini began to hang tight while trying to scroll the document even up / down, even left / right.

Steps to Reproduce:
1. open the file
2. twist the mouse wheel
3. the program freezes, the candy is spinning,
4. A hung LibreOffice eats off 99.3-99.7% of processor resources

Actual Results:
the computer sends an error report in Apple

Expected Results:
everything worked fine before the upgrade


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ru
Module: StartModule
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
Comment 1 Alex Thurgood 2018-12-04 09:26:23 UTC
@RuslanVa : is the freezing particular to any Calc document, or does it happen with any spreadsheet ?

If it is with a particular Calc document, ideally in order to be able to confirm, we would need to have an anonymized version with which to test.

Setting to NEEDINFO

You mention that you are using a MacMini - please also provide the specification of this machine, including RAM, and processor, and the total number of fonts installed.
Comment 2 RuslanVa 2018-12-04 15:59:30 UTC
Hello.
I apologize for the machine translation.
First, I want to emphasize that before the upgrade to the new version everything worked perfectly.
As for your question, I can tell the following: if I create a new file, then moving the cursor and scrolling with the mouse is normal. But it is necessary to make in the adjacent several cells (20-30 pieces) of any data, then after that the mouse scrolls up the process.

The computer has 236 fonts installed.

About my computer:
  Model Name: Mac mini
  Model ID: Macmini7.1
  Processor Name: Intel Core i5
  Processor speed: 2.6 GHz
  Number of processors: 1
  Total number of cores: 2
  Level 2 cache (in each core): 256 KB
  L3 cache: 3 MB
  Memory: 8 GB
  Boot ROM Version: 236.0.0.0.0
Comment 3 Xisco Faulí 2018-12-05 10:22:01 UTC
Hello RuslanVa,
Could you please paste the info from Help - about LibreOffice ?

OTOH, to be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 4 RuslanVa 2018-12-05 16:52:16 UTC
Версия: 6.1.3.3
ID сборки: 502e2001d4af96907b8ef3a795b2d9230cf93f0e
Потоков ЦП: 4; ОС:Mac OS X 10.14.1; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group threaded


The above cited the requested information.

Resetting the profile did not solve the problem.
A program running in safe mode crashes after scrolling the mouse wheel.

Noticed another point. After opening the document, if you click on another cell with the mouse, the first cell remains selected.
Comment 5 RuslanVa 2018-12-05 16:55:04 UTC
Created attachment 147306 [details]
two cursors
Comment 6 Xisco Faulí 2018-12-12 16:49:44 UTC
Hi RuslanVa,
oh, I see you're using Mac OS X 10.14.1 and LibreOffice Vanilla.
A new version 6.1.3.4 was released last week fixing a problem with Manjaro.
Could you please update LibreOffice and recheck?
Comment 7 RuslanVa 2018-12-13 17:38:32 UTC
Hello Xisco Faulí.
I made a factory reset for the macmini. Then he installed LibreOffice from App Store. The problem persists.
Removed the Office from App Store and downloaded the dmg file from the site http://libreoffice-mirror.rbc.ru/pub/libreoffice/libreoffice/stable/6.1.3/mac/x86_64/LibreOffice_6.1.3_MacOS_x86-64.dmg.

Everything works great))
So version 6.1.3.2 is now installed.
Comment 8 Alex Thurgood 2018-12-20 08:33:27 UTC
I would mark this as a duplicate of bug 121778
Comment 9 Alex Thurgood 2018-12-20 08:34:00 UTC

*** This bug has been marked as a duplicate of bug 121778 ***