Download it now!
Bug 121912 - PDF Export of odt documents to pdf -created pdf document is not readable in Acrobat reader
Summary: PDF Export of odt documents to pdf -created pdf document is not readable in A...
Status: RESOLVED DUPLICATE of bug 121725
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-12-04 20:08 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2018-12-05 08:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zip file with documents and screenshot to show the bug (103.03 KB, application/x-zip-compressed)
2018-12-04 20:08 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2018-12-04 20:08:22 UTC
Created attachment 147291 [details]
zip file with documents and screenshot to show the bug

Export of odt documents with LO 6.2 beta 1 delivers pdf documents not readable by Acrobat reader.
Tested with
Version: 6.2.0.0.beta1+ (x64)
Build ID: 02a8982aa505480fe744991bfa41efdc1436e60e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2018-12-04_05:56:47
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
 
Steps to reproduce:
- open the attached document "Protokoll 2018-11-07.odt"
- export it via File - Export as - Export as pdf
- export options: JPEG compression 80% (, reduce image resolution 300 DPI)
-> created document in the test: "Protokoll 2018-11-07_LO_6.2.pdf"

When I try to open the created pdf document with Acrobat reader an error message appears (s. "Screenshot pdf-Fehler 2018-12-04 205303.jpg").

The same document exported to pdf with LO 6.1.4.1 is OK ("Protokoll 2018-11-07_LO_6.1.4.1.pdf"), tested with
Version: 6.1.4.1 (x64)
Build-ID: 25073d18caee244880112e52c4a7e71f6081b3a9
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 1 m.a.riosv 2018-12-04 22:50:09 UTC
Seems the pdf is generated as hybrid even the option is no marked.

Reproducible.

Last good for me.
Version: 6.1.4.1 (x64)
Build ID: 25073d18caee244880112e52c4a7e71f6081b3a9
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: es-ES (es_ES); Calc: CL

First bad when I see
Versión: 6.2.0.0.beta1+ (x64)
Id. de compilación: e45c30858dec1dd705b9144fab981a3c8819ba96
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2018-12-03_12:04:06
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Bad
Versión: 6.2.0.0.beta1+ (x64)
Id. de compilación: 02a8982aa505480fe744991bfa41efdc1436e60e
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2018-12-04_05:56:47
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Bad
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 16d12d50c2bfd924d2a7e6946896526a15a150d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-04_00:57:42
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 2 m.a.riosv 2018-12-04 22:51:04 UTC
I have done the triage with calc.
Comment 3 Mike Kaganski 2018-12-05 08:02:22 UTC
This is not a hybrid PDF; it's simply a ODF file saved with extension PDF. The problem is commit 02a5cbb9814dc224114dfbf3bc0b6c53658450c9, after which LO breaks filter name in Save As dialog, and then falls back to the default export filter (ODF).

*** This bug has been marked as a duplicate of bug 121725 ***