Bug Hunting Session
Bug 121965 - Firebird: Base crashed when I created a new table in design mode with long Cyrillic field name
Summary: Firebird: Base crashed when I created a new table in design mode with long Cy...
Status: RESOLVED DUPLICATE of bug 121810
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Firebird-Default
  Show dependency treegraph
 
Reported: 2018-12-07 17:34 UTC by Roman Kuznetsov
Modified: 2018-12-07 20:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error window (21.51 KB, image/png)
2018-12-07 17:39 UTC, Roman Kuznetsov
Details
After button More... in Windows (21.94 KB, image/png)
2018-12-07 20:19 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-12-07 17:34:43 UTC
Description:
Firebird: Base crashed when I created a new table in design mode with long Cyrillic field name

crashreport.libreoffice.org/stats/crash_details/4f4b39d1-024a-4b2b-88d2-34c1392e5aa7

Version: 6.2.0.0.beta1+
Build ID: e18c4c5f55f12725821e2d357f251ae1c548217a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-11-29_16:39:51
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Xubuntu 17.10 64 bit

Steps to Reproduce:
1. Create a new Base Database
2. Select Firebird
3. Do not register database
4. Create Table in Design view
5. Enter into Field Name оченьоченьоченьдлиннаятаблица
6. Save a table
7. Enter any table name in dialogue "Save as" and push OK
8. No primary key - select NO 
9. You'll see error message
10. Push "More"
11. You'll see crash window, push OK and see at crash report window

Actual Results:
LO is crashed

Expected Results:
LO shows some warning window as for very long English field name


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-12-07 17:39:59 UTC
Created attachment 147358 [details]
Error window
Comment 2 Drew Jensen 2018-12-07 20:00:03 UTC
Using Ubuntu 18.04 and LO6.2Beta1 (30-11-18) and 6.3Alpha0 (01-12-18) (en local and en language) I am unable to reproduce a crash if I do not touch the more button on the error dialog.

Using the string in your example for both field and table names, the error dialog is appropriate, and clearing the dialog, without hitting more, then discarding the change or shortening the strings the application continues unfazed.

I believe this is a duplicate of an open error that has to do with the 'More' feature on the error dialog proper, not the SQL error handling per se.

I won't set it to that just yet though - if you crash on your system without clicking the More button that is different.
Comment 3 Terrence Enger 2018-12-07 20:05:41 UTC
Working on debian-buster, I have failed to reproduce the crash in
either linux dbgutil daily bibisect repository version 2018-12-07 or a
local build of commit b7f1b4c0.
Comment 4 Roman Kuznetsov 2018-12-07 20:18:59 UTC
(In reply to Drew Jensen from comment #2)
> Using Ubuntu 18.04 and LO6.2Beta1 (30-11-18) and 6.3Alpha0 (01-12-18) (en
> local and en language) I am unable to reproduce a crash if I do not touch
> the more button on the error dialog.
> 
> Using the string in your example for both field and table names, the error
> dialog is appropriate, and clearing the dialog, without hitting more, then
> discarding the change or shortening the strings the application continues
> unfazed.
> 
> I believe this is a duplicate of an open error that has to do with the
> 'More' feature on the error dialog proper, not the SQL error handling per se.
> 
> I won't set it to that just yet though - if you crash on your system without
> clicking the More button that is different.

I get crash only in Linux (Xubuntu) and only if I push button "More..."

In Windows 

Версия: 6.2.0.0.beta1 (x64)
ID сборки: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: CL

I got after "More..." else one window (see attach)
Comment 5 Roman Kuznetsov 2018-12-07 20:19:32 UTC
Created attachment 147364 [details]
After button More... in Windows
Comment 6 Drew Jensen 2018-12-07 20:25:11 UTC
Well then let's call it a dupe

*** This bug has been marked as a duplicate of bug 121810 ***