Bug 121984 - Compatibility mode setting for Justified text terminated with linebreak (<shift>+<enter>) should be false--to not justify the line by default, probably should follow our last line of justified paragraph handling as set
Summary: Compatibility mode setting for Justified text terminated with linebreak (<shi...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-08 16:12 UTC by zyklon87
Modified: 2018-12-20 16:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example (112.95 KB, image/png)
2018-12-08 16:20 UTC, zyklon87
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zyklon87 2018-12-08 16:12:17 UTC
Description:
When I insert a real newline (i.e. "Shift + Enter") after a certain justification-formatted paragraph, the last line of the paragraph above that newline gets force-formatted to an extreme justification. That for example means, that when there are just two words in that line, the second word gets completely right-aligned, so that an enormous amount of space gets inserted between two words.

I don’t think that this makes any sense. In the salutation I for example often write “Best regards,[REAL_NEWLINE]Frank” for the spacing not getting too big. Another use-case for me is when I want to arrange several points of a bullet list, which consist of more lines but should just get one bullet. I think creating new formats for these kinds of content/arrangements would be overkill, and I don’t see an advantage in the current behavior, which is why I think that this is a bug.

⇒ A maximum amount of good-looking space between the words of a paragraph should always be respected. When a line (maybe just the last line) of a justified paragraph would violate that maximum space, this line should be left-aligned instead.

Steps to Reproduce:
1. Create a new document and select justification ["Ctrl + B" (at least for Germany)].
2. Write two words and hit "Shift + Enter" for avoiding paragraph spacing to the next line.

Actual Results:
The two words are completely left- and right-aligned.

Expected Results:
The space between those two words is way too gigantic, and justification should be altered to left-alignment for that line.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 zyklon87 2018-12-08 16:20:52 UTC
Created attachment 147385 [details]
Example
Comment 2 V Stuart Foote 2018-12-08 22:13:03 UTC
Confirmed on Windows 10 Home 64-bit en-US (1803) with
Version: 6.3.0.0.alpha0+ (x64)
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-07_01:25:50
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Any line of text inside a paragraph with justified text terminated with <Shift>+<Enter> stretches full width of paragraph. Including the last line which should honor settings of the Paragraph Style -> Alignment -> Last line drop list (Start, Centered, Justified).

The Shift+Enter ending forces a Justified spacing that is too wide.
Comment 3 Xisco Faulí 2018-12-12 17:52:36 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

@Regina, any opinion here?
Comment 4 Regina Henschel 2018-12-12 19:12:15 UTC
(In reply to Xisco Faulí from comment #3) 
> @Regina, any opinion here?

Goto Tools > Options > LO Writer > Compatibility
Make sure, that the option "Expand word space on lines with manual line breaks in justified paragraphs" is not checked.
Comment 5 Xisco Faulí 2018-12-12 19:17:51 UTC
(In reply to Regina Henschel from comment #4)
> (In reply to Xisco Faulí from comment #3) 
> > @Regina, any opinion here?
> 
> Goto Tools > Options > LO Writer > Compatibility
> Make sure, that the option "Expand word space on lines with manual line
> breaks in justified paragraphs" is not checked.

Hi Regina,
Thanks for your comment. Then it's the expected behaviour. OTOH,check that option if you don't want that behaviour.
Closing as RESOLVED NOTABUG
Comment 6 zyklon87 2018-12-15 18:02:12 UTC
I don’t see any sense in this option. Also the reaction of others here being able to “reproduce this bug” shows that, too.

Can that thus be deactivated by default, please? It’s pretty annoying.
Comment 7 V Stuart Foote 2018-12-15 19:12:31 UTC
The justification after a line break was added in OOo 2.0 era (see also i13507) and then UI was adjusted to "Allow configuration of behavior when a line break is inserted" (see also i45491)

Between i13507 (2004) and i45491 (2007) the default was enabled true to justify after line break-- but there was no UI to override. That was added for i45491, and the default enabled true compatibility setting was continued. 

I just verified that current Microsoft Word 2016 (16.0.11029.20045) continues this behavior with a line justified paragraphs being justified to full width (too much white space) when a line break is inserted. So it remains a legitimate "compatibility" setting.

Personally, I would think disabled false and non-justified is a better default. Some of the later discussions of i13507 and dupes suggest that might have been the better route.
Comment 8 V Stuart Foote 2018-12-15 19:25:33 UTC
Simple change to toggle behavior here:

https://opengrok.libreoffice.org/xref/core/officecfg/registry/schema/org/openoffice/Office/Compatibility.xcs#105
Comment 9 Franklin Weng 2018-12-20 11:20:23 UTC
(In reply to V Stuart Foote from comment #7)
> The justification after a line break was added in OOo 2.0 era (see also
> i13507) and then UI was adjusted to "Allow configuration of behavior when a
> line break is inserted" (see also i45491)
> 
> Between i13507 (2004) and i45491 (2007) the default was enabled true to
> justify after line break-- but there was no UI to override. That was added
> for i45491, and the default enabled true compatibility setting was
> continued. 
> 
> I just verified that current Microsoft Word 2016 (16.0.11029.20045)
> continues this behavior with a line justified paragraphs being justified to
> full width (too much white space) when a line break is inserted. So it
> remains a legitimate "compatibility" setting.
> 
> Personally, I would think disabled false and non-justified is a better
> default. Some of the later discussions of i13507 and dupes suggest that
> might have been the better route.

Since there has been a setting about the behavior of justifying in Format - Paragraph - Options, I didn't see any necessity of this "compatibility" option.
Comment 10 Heiko Tietze 2018-12-20 16:03:45 UTC
We talked about this topic in the design and ESC meetings. While UX people agreed with changing the default there are serious concerns from the developers. LibreOffice aims for best compatibility with MS Word and switching the option off will produce different layouts between the two programs. So WF.

OTOH, Franklin's comment 9 about the paragraph setting should be considered as bug. If the manual break spawns over the full line it could be possible to switch it off with the paragraph style - if this is stored in the format and properly taken into MS documents. I suggest to file another ticket with the needsdevAdvice flag.