Download it now!
Bug 121989 - Paste text gets broken
Summary: Paste text gets broken
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2018-12-08 22:27 UTC by Szasz-Fabian Jozsef
Modified: 2018-12-09 20:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szasz-Fabian Jozsef 2018-12-08 22:27:37 UTC
Description:
At a certain point the paste with Ctrl-V gets broken. Libreoffice won't paste anything coming other applications (regardless of rich/plain text). It keeps pasting the last copied text from Libreoffice.

Steps to Reproduce:
Work in Libreoffice and other applications (Adobe, Notpad++)
1. Copy text in InDesign, Notepad++
2. Paste in Libreoffice

Actual Results:
Libreoffice pastes an earlier clipboard content

Expected Results:
Paste the clipboard's actual content


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Locale: en-US
Module: TextDocument
OS: Windows 10 Pro 64
Comment 1 Dieter 2018-12-09 08:54:47 UTC
I cpuldn't reproduce with Evernote and

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Oliver Brinzing 2018-12-09 12:52:09 UTC
this issue is maybe a duplicate of:

EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents
https://bugs.documentfoundation.org/show_bug.cgi?id=62196
Comment 3 Dieter 2018-12-09 20:02:44 UTC
(In reply to Oliver Brinzing from comment #2)
> this issue is maybe a duplicate of:
> 
> EDITING: copy-paste from non-LibO-text-source pastes previous clipboard
> contents
> https://bugs.documentfoundation.org/show_bug.cgi?id=62196

Oliver, I think you're right => RESOLVED DUPICATE

Szasz-Fabian, if you don't agree feel free to change it back to UNCONFIRMED with a short explanation.

*** This bug has been marked as a duplicate of bug 62196 ***