Download it now!
Bug 121998 - Terrible UI if screen scale in Windows is 150% or more
Summary: Terrible UI if screen scale in Windows is 150% or more
Status: RESOLVED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-09 19:07 UTC by Alexey Khrulev
Modified: 2018-12-09 22:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Draw UI on Windows 10 with screen scale 150% (50.32 KB, image/png)
2018-12-09 19:08 UTC, Alexey Khrulev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Khrulev 2018-12-09 19:07:09 UTC
Description:
Program is almost useless on 4K monitors because a lot of user interface elements are wrong or clipped.

Steps to Reproduce:
1. Use Draw on Windows 10 with screen scale 150% or more.

Actual Results:
A LOT of UI bugs. See examples on attached screenshots.
I even do not describe all bugs because it is obvious.


Expected Results:
Normal UI


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.1.3.2 (x64)
ID сборки: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Потоков ЦП: 8; ОС:Windows 10.0; Отрисовка ИП: GL; 
Локаль: ru-RU (ru_RU); Calc: group threaded
Comment 1 Alexey Khrulev 2018-12-09 19:08:30 UTC
Created attachment 147403 [details]
Draw UI on Windows 10 with screen scale 150%
Comment 2 V Stuart Foote 2018-12-09 21:43:25 UTC
corrected for 6.1.4 release, a 6.2.0 build, or current master/6.3.0 build

*** This bug has been marked as a duplicate of bug 119020 ***
Comment 3 V Stuart Foote 2018-12-09 22:11:34 UTC
There were actually two issues shown here--the obvious is the scaling as 8-bit rather than 24-bit color depth of bug 119020. The other is font handling, as for bug 120204 and bug 119829, was patched at 6.1.4 [1], and refactored for 6.2.0 [2]

=-ref-=
[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=ac39aba9b2d08b061b0eef651f5ebc7a84391171&h=libreoffice-6-1

[2] https://cgit.freedesktop.org/libreoffice/core/commit/?id=01a782d2ceb741d20721b44d26d862d80b47d226