Download it now!
Bug 122032 - FILEOPEN DOCX: Bold style show in auto numeric list in a table for .docx but not must
Summary: FILEOPEN DOCX: Bold style show in auto numeric list in a table for .docx but ...
Status: RESOLVED DUPLICATE of bug 120546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2018-12-12 05:27 UTC by seven
Modified: 2020-01-15 07:30 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document where bold style showed only in LibreOffice (15.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-12 05:27 UTC, seven
Details
Documet show bold style for all editors after save in libreoffice (11.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-12 05:28 UTC, seven
Details
Comparison LibreOffice 6.3 Master and MSO 2010 (35.67 KB, image/png)
2018-12-13 11:24 UTC, Xisco Faulí
Details
The example document in 6.4 (93.57 KB, image/png)
2020-01-14 22:52 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2018-12-12 05:27:50 UTC
Created attachment 147455 [details]
Test document where bold style showed only in LibreOffice

See document s-test.docx
Item 1.2 in first column and 1.1 in second column is bold, but not must be (i need original normal style font)

If save document in s-test-2.docx bold style will be visible for MS office and LibreOffice
Comment 1 seven 2018-12-12 05:28:43 UTC
Created attachment 147456 [details]
Documet show bold style for all editors after save in libreoffice
Comment 2 seven 2018-12-12 05:30:03 UTC
Comment on attachment 147456 [details]
Documet show bold style for all editors after save in libreoffice

Saved document s-test.docx in libreoffice and get s-test-2.docx
Comment 3 Dieter 2018-12-12 13:45:28 UTC
I confirm it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

That's what I did:
1. Opened attachment 147455 [details] in Word 2016
2. Saved in word 2016
3. Reopened in LO
Comment 4 Xisco Faulí 2018-12-13 11:24:35 UTC
Created attachment 147493 [details]
Comparison LibreOffice 6.3 Master and MSO 2010
Comment 5 Xisco Faulí 2018-12-13 11:27:10 UTC
Reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e


but not in

LibreOffice 3.5.0 
Build ID: d6cde02
Comment 6 raal 2019-01-10 15:47:09 UTC
This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák ; Could you possibly take a look at this one?
Thanks

20e1efcb952561544a3f6a401c3b9fbd491dbae8 is the first bad commit
commit 20e1efcb952561544a3f6a401c3b9fbd491dbae8
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 20:28:23 2015 +0800

    source-hash-df07d6cb9f62c0a2c4b29bd850d4efb4fcd4790b
    
    commit df07d6cb9f62c0a2c4b29bd850d4efb4fcd4790b
    Author:     Luboš Luňák <l.lunak@collabora.com>
    AuthorDate: Thu May 29 14:31:20 2014 +0200
    Commit:     Luboš Luňák <l.lunak@collabora.com>
    CommitDate: Thu May 29 14:34:50 2014 +0200
    
        handle direct formatting for numbering in .docx (bnc#875717)
Comment 7 Xisco Faulí 2019-01-11 09:50:52 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2019-06-11 17:09:47 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2019-06-12 15:13:29 UTC
Hi Miklos,
This issue was initially closed as duplicated of bug 108630 since the bisection was pointing to the same commit.
I've just found bug 108630 got fixed by your commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=00ac19068de5e120d1620a719aa64f1203c639ae for bug 120548.
I thought you could be interested in this issue...
Comment 10 Timur 2019-09-06 09:25:32 UTC
DOCX attachment 147455 [details] is from WPS. But issue reproduced with LO 6.4+ even if DOCX resaved in MSO. Minor.
Comment 11 Gabor Kelemen 2020-01-14 22:52:34 UTC
Created attachment 157156 [details]
The example document in 6.4

This started to look good since:

author	Jan-Marek Glogowski <jan-marek.glogowski@extern.cib.de>	2019-11-01 10:39:47 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2019-12-06 14:50:22 +0100

tdf#120546 fix DOCX overriding numrule format

bibisected using bibisect-linux-64-6.4
Comment 12 NISZ LibreOffice Team 2020-01-15 07:30:21 UTC
Marking as duplicate per my last comment, also changing meta since this was only a bullets+numbering problem, not a table one.

*** This bug has been marked as a duplicate of bug 120546 ***