Bug 122068 - Broken slide preview when opening .pptx if picture mostly fills the slide
Summary: Broken slide preview when opening .pptx if picture mostly fills the slide
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: Slide-Page-Pane Slide-Show PPTX
  Show dependency treegraph
 
Reported: 2018-12-13 08:27 UTC by keddad
Modified: 2019-10-31 03:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problematic file (966.19 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-01-24 17:51 UTC, Buovjaga
Details
Screenshot of broken preview (7.80 KB, image/png)
2019-01-24 17:52 UTC, Buovjaga
Details
Screenshot of affected slide (68.91 KB, image/png)
2019-01-24 17:53 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keddad 2018-12-13 08:27:47 UTC
Description:
When opening .pptx with pictures, preview of slides which contain just one big picture look broken. 
Here how miniature looks:
https://ibb.co/kXXQ7TS
And how normal slide looks:
https://ibb.co/Lx43X03
Here is the file for example:
https://yadi.sk/i/nikoCDDTORU1hA

Steps to Reproduce:
1. Open File
2. Look on Preview
3.

Actual Results:
Preview is broken

Expected Results:
Normal preview


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Durgapriyanka 2018-12-13 19:23:15 UTC
Thank you for reporting the bug. I can not reproduce the bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 keddad 2018-12-13 19:49:43 UTC
It is pretty strange, looks like bug occurs only with this file. I'll try to find the issue
Comment 3 Buovjaga 2019-01-24 17:51:16 UTC
Created attachment 148606 [details]
Problematic file

Slides look fine for me on Linux and Windows.

Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: bb30e9e591d5f9f913b3cd8fbaa3c5e412b509bd
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 23 January 2019
Comment 4 Buovjaga 2019-01-24 17:52:37 UTC
Created attachment 148607 [details]
Screenshot of broken preview
Comment 5 Buovjaga 2019-01-24 17:53:02 UTC
Created attachment 148608 [details]
Screenshot of affected slide
Comment 6 QA Administrators 2019-09-30 02:52:32 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-10-31 03:37:51 UTC
Dear keddad,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp