Bug 122094 - FILEOPEN XLSX, Conditional formatting condition not working the same in LO as MSO.
Summary: FILEOPEN XLSX, Conditional formatting condition not working the same in LO as...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
: 122097 (view as bug list)
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-12-14 11:43 UTC by NISZ LibreOffice Team
Modified: 2020-12-21 11:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original spreadsheet. (16.88 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-14 11:44 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (324.79 KB, image/png)
2018-12-14 11:44 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 11:43:24 UTC
Description:
Greater than 0 and Lesser or equal 0 condition in conditional formatting not working the same in LO as in MSO. 

Steps to Reproduce:
    1. Create a new xlsx file.
    2. Create 2 conditional formatting with the same range one with greater than 0 and one with lesser or equal 0 that changes the background.
    3. Write some numbers in some of the formatted cells (3 2 -1)
    4. Write some text in one of the formatted cells, notice it changes according to the greater than 0 formatting.
    5. Save it.
    6. Open the file in LO and notice the changes.

Actual Results:
The cell with the text has a white background.

Expected Results:
Expected results: It should have the background of the greater than 0 formatting.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 11:44:06 UTC
Created attachment 147525 [details]
The original spreadsheet.
Comment 2 NISZ LibreOffice Team 2018-12-14 11:44:33 UTC
Created attachment 147526 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Durgapriyanka 2018-12-14 19:06:41 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 

Microsoft excel 2007

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2018-12-18 13:45:26 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Buovjaga 2019-01-25 15:04:54 UTC
Repro in 3.3.0 on Win 10
Comment 6 László Németh 2020-12-08 17:55:03 UTC
@Tibor: I don't think that this is an intended behavior of Excel, showing conditional formatting, if the cell value doesn't meet the condition, see http://officeopenxml.com/SSstyles.php or am I wrong?
Comment 7 NISZ LibreOffice Team 2020-12-18 11:24:03 UTC
*** Bug 122097 has been marked as a duplicate of this bug. ***
Comment 8 NISZ LibreOffice Team 2020-12-21 11:55:54 UTC
After thinking about this a bit, it seems to us that considering "test" greater than 0 or 300 does not make much sense.
So here it's better to not imitate Excels behavior.