Bug 122101 - FILEOPEN XLSM, Some conditional formatting has dissapeared its conditions after opening LO
Summary: FILEOPEN XLSM, Some conditional formatting has dissapeared its conditions aft...
Status: RESOLVED DUPLICATE of bug 122102
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, filter:xlsx
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-12-14 12:10 UTC by NISZ LibreOffice Team
Modified: 2019-01-09 15:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original spreadsheet. (581.07 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2018-12-14 12:11 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (491.75 KB, image/png)
2018-12-14 12:11 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 12:10:48 UTC
Description:
When the attached spreadsheet gets opened in LO some of the conditional formatting is missing its condition.

Steps to Reproduce:
    1. Open the attached spreadsheet in LO and MSO.
    2. Go to page 2. ERDF Pps (WP-BL) and go to conditional formatting management for that page (in LO you need to select the whole page to see it)
    3. Notice that some of the rules are missing their condition.

Actual Results:
Some of the rules are missing their condition.

Expected Results:
They should keep their condition.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 12:11:16 UTC
Created attachment 147535 [details]
The original spreadsheet.
Comment 2 NISZ LibreOffice Team 2018-12-14 12:11:34 UTC
Created attachment 147536 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Roman Kuznetsov 2018-12-15 09:57:44 UTC
confirm in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-01-09 15:21:45 UTC
Root cause seems the same as in bug 122102

*** This bug has been marked as a duplicate of bug 122102 ***