Bug 122102 - FILEOPEN XLSX, Conditional formatting goes missing when opened in LO.
Summary: FILEOPEN XLSX, Conditional formatting goes missing when opened in LO.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords: dataLoss, filter:xlsx
: 122101 122105 (view as bug list)
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-12-14 12:14 UTC by NISZ LibreOffice Team
Modified: 2021-01-11 11:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The original spreadsheet. (152.48 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-14 12:14 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (361.80 KB, image/png)
2018-12-14 12:14 UTC, NISZ LibreOffice Team
Details
Screenshot of a simplified example in Excel and Calc (97.15 KB, image/png)
2019-07-17 10:47 UTC, Gabor Kelemen (allotropia)
Details
Simplified example file from Excel (9.72 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-07-17 10:48 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 12:14:09 UTC
Description:
When the attached spreadsheet is opened in LO one of the conditional formatting has lost its condition and when clicked on it it shows that there is no formatting and after that goes missing completely.

Steps to Reproduce:
    1. Open the attached spreadsheet in LO and MSO.
    2. Go to the conditional formatting manager in both.
    3. Check out the one which is missing its condition in LO.
    4. Close the window then go back to the manager see that its now missing.

Actual Results:
Some of the conditional formatting is missing in LO.

Expected Results:
It should still be there even if opened in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 12:14:37 UTC
Created attachment 147538 [details]
The original spreadsheet.
Comment 2 NISZ LibreOffice Team 2018-12-14 12:14:58 UTC
Created attachment 147539 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Roman Kuznetsov 2018-12-15 10:04:12 UTC
confirm in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

conditions for range C57:D61 dissapeare in LO
Comment 4 Xisco Faulí 2019-01-09 15:18:25 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 5 Xisco Faulí 2019-01-09 15:21:45 UTC
*** Bug 122101 has been marked as a duplicate of this bug. ***
Comment 6 Gabor Kelemen (allotropia) 2019-02-21 14:10:46 UTC
*** Bug 122105 has been marked as a duplicate of this bug. ***
Comment 7 Gabor Kelemen (allotropia) 2019-07-17 10:47:44 UTC
Created attachment 152828 [details]
Screenshot of a simplified example in Excel and Calc

If the condition is not given as a fixed string in Excel then importing the rule fails when using "Given text" type and cell reference inside the same file.

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 49422a469646ad8be43ba828ca24c2484c26b9e8
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-08_00:50:19
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 8 Gabor Kelemen (allotropia) 2019-07-17 10:48:17 UTC
Created attachment 152829 [details]
Simplified example file from Excel
Comment 9 Commit Notification 2020-12-16 19:53:13 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0101975f8eac650bb87c4af81157cb33a6309e0e

tdf#122102 XLSX import: fix "contains" conditional formatting

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-12-17 11:05:33 UTC
Nice fix! Verified in

Version: 7.2.0.0.alpha0+
Build ID: 4484accf4d331a95ebf8475d6cd91950f4c27bcc
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Tibor Nagy, thanks for fixing this issue!!
Comment 11 Commit Notification 2020-12-17 11:06:54 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/4bca4f507c064c18880bd8283aaba567865d2462

tdf#122102 XLSX import: fix "contains" conditional formatting

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 NISZ LibreOffice Team 2021-01-11 11:09:28 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 96bafa464ebdbce3ef04bec9beae5e745bb37794
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!