Bug 122105 - FILEOPEN XLSX, Conditional formatting only has its range left when opened in LO.
Summary: FILEOPEN XLSX, Conditional formatting only has its range left when opened in LO.
Status: RESOLVED DUPLICATE of bug 122102
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-12-14 12:42 UTC by NISZ LibreOffice Team
Modified: 2019-02-21 14:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original spreadsheet. (18.87 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-14 12:43 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (356.99 KB, image/png)
2018-12-14 12:43 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 12:42:46 UTC
Description:
When the attached spreadsheet gets opened in LO the conditional formatting only has its range left.


Steps to Reproduce:
    1. Open the attached spreadsheet in LO and MSO.
    2. Go to the conditional formattin manager in both.
    3. Notice the difference in LO.

Actual Results:
The condition and format are missing in LO.

Expected Results:
The conditional formatting should stay the same as it was in MSO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 12:43:34 UTC
Created attachment 147546 [details]
The original spreadsheet.
Comment 2 NISZ LibreOffice Team 2018-12-14 12:43:54 UTC
Created attachment 147547 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 raal 2018-12-16 16:44:21 UTC
Confirm with Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 1; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-12_03:38:09
and 6.0.7.3

In 4.1 is not condition imported at all
Comment 4 Gabor Kelemen (allotropia) 2019-02-21 14:10:46 UTC
I think this is has the same "condition pointing to another sheet" issue as bug #122102

*** This bug has been marked as a duplicate of bug 122102 ***