Bug Hunting Session
Bug 122109 - FILEOPEN XLSX, Table loses its style when opened in LO.
Summary: FILEOPEN XLSX, Table loses its style when opened in LO.
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Table-Styles XLSX
  Show dependency treegraph
 
Reported: 2018-12-14 13:16 UTC by NISZ LibreOffice Team
Modified: 2019-03-08 06:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
An Excel spreadsheet with a table with a style. (18.24 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-12-14 13:16 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc. (295.81 KB, image/png)
2018-12-14 13:17 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-14 13:16:17 UTC
Description:
When you create a table in Excel with a style and open it in LO it loses its style.

Steps to Reproduce:
    1. Create a new xlsx in MSO.
    2. Insert a table and give it a style.
    3. Save and exit the file.
    4. Open it in LO.

Actual Results:
The table doesn’t have a style in LO.

Expected Results:
It should keep its style that was given to it in MSO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-14 13:16:43 UTC
Created attachment 147554 [details]
An Excel spreadsheet with a table with a style.
Comment 2 NISZ LibreOffice Team 2018-12-14 13:17:30 UTC
Created attachment 147555 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 3 Durgapriyanka 2018-12-14 19:35:20 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 

Microsoft excel 2007

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

I do see that the table loses its style when opened in LO.
Comment 4 Roman Kuznetsov 2018-12-17 11:16:13 UTC
Do you mean function "Format as Table"?
Comment 5 Xisco Faulí 2018-12-18 13:47:03 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 6 Gabor Kelemen 2018-12-18 14:16:25 UTC
We are going in circles :)

*** This bug has been marked as a duplicate of bug 112371 ***
Comment 7 Aron Budea 2019-03-08 06:04:45 UTC

*** This bug has been marked as a duplicate of bug 66377 ***