Download it now!
Bug 122117 - No Toggle effect On/Off in Edit > Track Changes
Summary: No Toggle effect On/Off in Edit > Track Changes
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2018-12-15 02:18 UTC by C
Modified: 2019-01-17 12:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C 2018-12-15 02:18:11 UTC
Description:
There is no signal to show the ON or OFF status of Edit > Track Changes > Record

I believe that a change in icon was intended but is missing.

--
Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.18.04.1
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: en-US (en); Calc: group

Steps to Reproduce:
1.open a document
2.press in menu Edit > Track Changes > Record
3.delete some arbitrary text... it should turn tan
4.open  in menu Edit > Track Changes > Record ... there is no change, though it is recording

Actual Results:
1.
2.
3.deleted  text should turn tan
4.there is no change, though it is recording

Expected Results:
change in icon or menu item AND a change of some icon or indicator in status bar


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2018-12-15 13:08:08 UTC
When I press record changes, the icon gets highlited, so I can't confirm your oberservation

It might be useful to add something to the status bar. But that are two different things, I think.
Comment 2 Xisco Faulí 2019-01-17 12:29:17 UTC
Hello C,
I wouldn't recommend you to use x11, instead use gtk/gtk3 or kde backends...
Anyway, i've just tried in

Version: 6.3.0.0.alpha0+
Build ID: 5e89aad61e143ad6a52291ef7065f5b22e348c85
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and there's a thin border around the border indicating it's toggled.
closing as resolved notabug