Bug 122119 - UI checkbox is not fully displayed in Font features (Format cells dialog)
Summary: UI checkbox is not fully displayed in Font features (Format cells dialog)
Status: REOPENED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords: bibisected, bisected
: 121640 (view as bug list)
Depends on:
Blocks: Cell-Format-Dialog
  Show dependency treegraph
 
Reported: 2018-12-15 07:53 UTC by Emil Tanev
Modified: 2019-01-13 13:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (345.84 KB, image/png)
2018-12-15 07:53 UTC, Emil Tanev
Details
Font features from kompi (22.34 KB, image/png)
2018-12-15 10:34 UTC, Roman Kuznetsov
Details
scr-1 (115.46 KB, image/png)
2018-12-16 14:30 UTC, Vera Blagoveschenskaya
Details
scr2 (138.64 KB, image/png)
2018-12-16 14:30 UTC, Vera Blagoveschenskaya
Details
linux-libertine-G (339.87 KB, image/png)
2018-12-23 13:39 UTC, Vera Blagoveschenskaya
Details
Linux-biolinum-G (336.32 KB, image/png)
2018-12-23 13:40 UTC, Vera Blagoveschenskaya
Details
Example of non accessible options with KDE5 VCL plug-in (113.44 KB, image/png)
2019-01-13 13:41 UTC, RGB
Details
An example of GTK3 interface not fitting on laptop screen (125.14 KB, image/png)
2019-01-13 13:45 UTC, RGB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Tanev 2018-12-15 07:53:10 UTC
Created attachment 147568 [details]
screenshot

Open Calc
Open Format cells dialog - Font - Features
Issue - checkbox is hiddent (see screenshot)
Comment 1 Emil Tanev 2018-12-15 08:15:46 UTC
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 1; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-12_03:38:09
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Roman Kuznetsov 2018-12-15 10:34:20 UTC
Created attachment 147572 [details]
Font features from kompi
Comment 3 Roman Kuznetsov 2018-12-15 10:36:01 UTC
don't confirm

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 4 Vera Blagoveschenskaya 2018-12-16 14:30:19 UTC
Well, I can reproduce it for some fonts (see scr-1), but the workaround is to resize the window (see scr-2).

Emil, could you please recheck - is the checkbox became visible after resizing the window?

Version: 6.3.0.0.alpha0+
Build ID: e3e15d8c625cbf56e1f03d9ebde966e78844c7a4
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-13_20:10:25
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Vera Blagoveschenskaya 2018-12-16 14:30:36 UTC
Created attachment 147597 [details]
scr-1
Comment 6 Vera Blagoveschenskaya 2018-12-16 14:30:53 UTC
Created attachment 147598 [details]
scr2
Comment 7 Xisco Faulí 2018-12-18 16:36:22 UTC
I reported a similar problem in bug 121270 for GTK3
Comment 8 Xisco Faulí 2018-12-18 16:42:11 UTC
I can reproduce it with GTK2

Version: 6.3.0.0.alpha0+
Build ID: 6dc36d343aeacb3d1e14ec0c847937d63f4e68a7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Xisco Faulí 2018-12-18 16:50:35 UTC
So, the dialog was weld in https://cgit.freedesktop.org/libreoffice/core/commit/?id=842c71a1fae1def3e8b694ae3b820b34ad26bce4 and scrollbars were put in place. Later on, the toolbars were set to never https://gerrit.libreoffice.org/plugins/gitiles/core/+/3d70b1253f964fb75cd4b5915b8dd031ee54d5c7%5E%21 to fix bug 121270.

@Caolán, could be possible to calculate the full size of the dialog as before 842c71a1fae1def3e8b694ae3b820b34ad26bce4 ? This can be reproduced with carlito font and GTK2
Comment 10 Caolán McNamara 2018-12-19 10:12:09 UTC
looks like its not quite getting the full allocation it requested
Comment 11 Xisco Faulí 2018-12-19 10:33:50 UTC
*** Bug 121640 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2018-12-19 13:33:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b16992f92090f616af02ea46912ebde697c7780d%5E%21

tdf#122119 make fontfeature dialog size unlimited

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-12-19 15:50:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cd70a4614fc24d62e16a4ff6182d4fecfb6617d1%5E%21

tdf#122119 make fontfeature dialog size unlimited

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Vera Blagoveschenskaya 2018-12-23 13:39:14 UTC
Version: 6.3.0.0.alpha0+
Build ID: 2ee85baac60dde5238e42483d610edf28fcffc6b
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-22_16:58:18
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Bug is still reproducible, for ex, for 
- Linux Biolinum G
- Linux Libertine G

Please look at the screenshots
Comment 15 Vera Blagoveschenskaya 2018-12-23 13:39:41 UTC
Created attachment 147784 [details]
linux-libertine-G
Comment 16 Vera Blagoveschenskaya 2018-12-23 13:40:02 UTC
Created attachment 147785 [details]
Linux-biolinum-G
Comment 17 Timur 2018-12-24 14:58:56 UTC
Windows master looks OK. And has different features order. 
Not sure if KDE issue should be separated.
Comment 18 RGB 2019-01-13 13:39:59 UTC
Bug 121640 was closed as duplicated of this bug, even if it was about 6.2.0 beta 1 and this was originally about 6.3 alpha → changing earliest affected version accordingly. On next comment some screenshots with the problem.
Comment 19 RGB 2019-01-13 13:41:18 UTC
Created attachment 148289 [details]
Example of non accessible options with KDE5 VCL plug-in

An example that shows how some options are not accessible using the KDE5 VCL plug-in.
Comment 20 RGB 2019-01-13 13:45:31 UTC
Created attachment 148290 [details]
An example of GTK3 interface not fitting on laptop screen

In this screenshot, you can see how with the GTK3 VCL plug-in some controls are not accessible on small screens (it is a full screen capture on a 1366*768 device).
Comment 21 RGB 2019-01-13 13:49:04 UTC
Forgot to mention: screenshots taken on LibreOffice 6.2.0.2, 64 bits, under openSUSE Leap 15.0.