Download it now!
Bug 122137 - Mac fullscreen feature support in all apps of L.O.
Summary: Mac fullscreen feature support in all apps of L.O.
Status: RESOLVED DUPLICATE of bug 115284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-16 09:44 UTC by Janek
Modified: 2018-12-16 16:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek 2018-12-16 09:44:13 UTC
Description:
I would like to request an upgrade to LibreOffice that make it support one of the plenty macOS features called fullscreen. I would much appreciate that I could use L.O. in the fullscreen mode, because that way I can quickly switch between my opened files, plus I personally love this macOS feature.

Steps to Reproduce:
1.Open any app of L.O.
2.click on the green button in the top-left side of the window
3.

Actual Results:
The window stretches itself to fill the whole desktop from the menu bar at the top, to the dock at the bottom

Expected Results:
The app window should go fullscreen with the ability of multi-touch 3 or 4 finger swipe to return to the desktop or to jump to another fullscreen app.


Reproducible: Always


User Profile Reset: No



Additional Info:
Not much to discuss here. I have a simple feature request. That's all.
Comment 1 V Stuart Foote 2018-12-16 16:52:09 UTC
Nothing "simple" about this native macOS coding requirement. But believe it is wrapped up in ongoing work for bug 115284

*** This bug has been marked as a duplicate of bug 115284 ***