Bug Hunting Session
Bug 122140 - LO Base: Wrong date while setting default value
Summary: LO Base: Wrong date while setting default value
Status: RESOLVED DUPLICATE of bug 102945
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Base-UX
  Show dependency treegraph
 
Reported: 2018-12-16 15:58 UTC by Vera Blagoveschenskaya
Modified: 2018-12-16 16:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screen-1 (61.29 KB, image/png)
2018-12-16 15:59 UTC, Vera Blagoveschenskaya
Details
screen-2 (52.79 KB, image/png)
2018-12-16 15:59 UTC, Vera Blagoveschenskaya
Details
test file Firebird embedded, date field with default date, local en_us lang en_us (2.98 KB, application/vnd.oasis.opendocument.database)
2018-12-16 16:15 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-12-16 15:58:44 UTC
Description:
LO Base: Wrong date while setting default value

Steps to Reproduce:
1. LO Base, create new table
2. Set Date for some field
3. Set default value = for ex, 14.03.2008, see screen-1
4. Save changes

Actual Results:
Default date is changed. See screen-2
It is also changed if to switch between fields (date field and another one).

Expected Results:
Date is not changed


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: e3e15d8c625cbf56e1f03d9ebde966e78844c7a4
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-12-13_20:10:25
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Reproduced also for GTK3
Comment 1 Vera Blagoveschenskaya 2018-12-16 15:59:00 UTC
Created attachment 147606 [details]
screen-1
Comment 2 Vera Blagoveschenskaya 2018-12-16 15:59:15 UTC
Created attachment 147607 [details]
screen-2
Comment 3 Drew Jensen 2018-12-16 16:15:17 UTC
Created attachment 147608 [details]
test file Firebird embedded, date field with default date, local en_us lang en_us

Test system Ubuntu 18.04.1 (AMD64) LO6.2Beta1 (daily build 12/15)
Test file created with english dates and the string entered in the table designer was '02/01/18' which was then changed in the example format as '02/03/01'. 
I then changed the display format for the column, in the table view, to long dates and both the values added to new records and the string displayed in the table editor was again changed. 

Confirming issue, default date string being misread.

Reproduce:

1 - open attached base file
2 - open the table view for Table1
3 - enter a new record.
4 - close the table view and open the table design editor
5 - try to change the default date string

results
the conversion of the default date string to a date value is wrong.
Comment 4 Robert Großkopf 2018-12-16 16:18:50 UTC
It's a duplicate of 102945.
Every time you leave the field and enter it again the date will be set 2 days later. So you couldn't set a default and edit the table again without changing the default.

*** This bug has been marked as a duplicate of bug 102945 ***