Download it now!
Bug 122141 - Calc crashed in time PDF export file from 122130 (Crash in: libc-2.26.so)
Summary: Calc crashed in time PDF export file from 122130 (Crash in: libc-2.26.so)
Status: RESOLVED DUPLICATE of bug 121439
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-12-16 17:28 UTC by Roman Kuznetsov
Modified: 2018-12-17 22:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["libc-2.26.so"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-12-16 17:28:44 UTC
This bug was filed from the crash reporting server and is br-235c4f23-1877-47b7-a234-59cfd5161e4f.
=========================================

Версия: 6.1.3.2
ID сборки: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Потоков ЦП: 4; ОС:Linux 4.13; Отрисовка ИП: по умолчанию; VCL: gtk2; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group threaded

Open file https://bugs.documentfoundation.org/attachment.cgi?id=147585
Update all link (infobar)
Set Autofilter in column H-> only value 97,16
Export to PDF -> LO crashed

but, i can't repeat it else one
Comment 1 Oliver Brinzing 2018-12-17 17:54:21 UTC
confirming crash with:

Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

got error message before crash:

"vector <T> to long"
Comment 2 Oliver Brinzing 2018-12-17 17:55:35 UTC
no crash, if i clear the print ranges before export
Comment 3 Xisco Faulí 2018-12-17 22:57:31 UTC
Regression introduced by 5217a2a0bf27e496cc429ee45dff7c239b466ae6
Closing as RESOLVED DUPLICATED of bug 121439

*** This bug has been marked as a duplicate of bug 121439 ***