Download it now!
Bug 122150 - "intd" symbol and argument not exported in mathml
Summary: "intd" symbol and argument not exported in mathml
Status: RESOLVED DUPLICATE of bug 97049
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-17 09:35 UTC by vivien.guillet
Modified: 2018-12-26 12:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vivien.guillet 2018-12-17 09:35:23 UTC
Description:
"intd a" shows "∫a" in equation preview. mathml part in odf document is empty.

Note that related operator "int" works

"int a" shows "∫a" in equation preview. generated mathml is correct ;

<mo stretchy="false">∫</mo><mi>a</mi>



Steps to Reproduce:
1. type "intd a" in formula editor
2. save document
3. examine mathml in odf document

Actual Results:
<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
    <semantics>
        <annotation encoding="StarMath 5.0">intd a</annotation>
    </semantics>
</math>


Expected Results:
<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
    <semantics>
        <mrow>
            <mo stretchy="false">∫</mo><mi>a</mi>
        </mrow>
        <annotation encoding="StarMath 5.0">int a</annotation>
    </semantics>
</math>



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 vivien.guillet 2018-12-17 09:37:31 UTC
Typo in expected Results, real one is :

<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
    <semantics>
        <mrow>
            <mo stretchy="false">∫</mo><mi>a</mi>
        </mrow>
        <annotation encoding="StarMath 5.0">intd a</annotation>
    </semantics>
</math>
Comment 2 vivien.guillet 2018-12-17 09:59:54 UTC
Version: 5.2.7.2 (debian)
Comment 3 Regina Henschel 2018-12-17 16:49:09 UTC
You are using an old version. This was bug 97049, which was fixed in version 5.3.

Current versions are 6.1.3 and 6.0.7. https://www.libreoffice.org/download/download/
Comment 4 Xisco Faulí 2018-12-26 12:30:23 UTC

*** This bug has been marked as a duplicate of bug 97049 ***