Bug Hunting Session
Bug 122153 - CRASH closing LibreOffice while XML filter settings dialog is open
Summary: CRASH closing LibreOffice while XML filter settings dialog is open
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-17 10:30 UTC by Xisco Faulí
Modified: 2018-12-18 11:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["Dialog::Execute()"]


Attachments
sample document (14.29 KB, application/vnd.oasis.opendocument.database)
2018-12-17 10:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-12-17 10:30:49 UTC
Created attachment 147617 [details]
sample document

Steps to reproduce:
1. Open attached document
2. Edit the form
3. Tools - XML filter settings
4. Close LibreOffice
5. Close the XML filter settings dialog
-> Crash!

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: bdc82e277759a2df68855fce0a3fdd58f9b1ea66
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 1 Xisco Faulí 2018-12-17 10:35:03 UTC
@Caolán, I thought you could be interested in this issue...
Comment 2 Caolán McNamara 2018-12-17 16:26:22 UTC
modeless dialog with a confused history around its modality
Comment 3 Commit Notification 2018-12-17 21:07:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c58d4c1990df4dcdc09f0e5841069d6a42cd07cd%5E%21

Related: tdf#122153 set more correct dialog parents

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-12-17 21:07:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/cabc14a343142e53ab1ef0085b023bb7fadcf449%5E%21

Resolves: tdf#122153 keep Execute for modal dialogs

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-12-17 21:08:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c821da3ecc3c309be2ec2db204a4c853b53fa979%5E%21

Resolves: tdf#122153 keep Execute for modal dialogs

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-12-18 08:57:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/2421b42c006e1a9c9059c8a256685d2124f4e396%5E%21

Resolves: tdf#122153 keep Execute for modal dialogs

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-12-18 10:28:12 UTC
Hi Caolán,
I do reproduce it no longer crashes in 

Version: 6.3.0.0.alpha0+
Build ID: 6dc36d343aeacb3d1e14ec0c847937d63f4e68a7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

However, it might happen LibreOffice remains open in background when it's meant to be closed

Steps to reproduce:
1. Open attached document
2. Edit the form
3. Tools - XML filter settings
4. Click on New or Edit
5. Close LibreOffice
6. Close the XML filter settings dialog
-> LibreOffice seems to be closed but it remains open in background...

Should I reopen this issue or report a new issue ?
Comment 8 Xisco Faulí 2018-12-18 11:28:38 UTC
I reported bug 122153 for the problem mentioned in comment 7.

Closing this one as VERIFIED FIXED. Thanks for fixing this!!