Bug 122162 - Specific function for adding and deleting table-cells was deleted, but is still in help
Summary: Specific function for adding and deleting table-cells was deleted, but is sti...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2018-12-17 19:42 UTC by Hanif Bin Ariffin
Modified: 2019-05-16 10:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanif Bin Ariffin 2018-12-17 19:42:39 UTC
Description:
According to the official guide 
https://help.libreoffice.org/Writer/Adding_or_Deleting_a_Row_or_Column_to_a_Table_Using_the_Keyboard

One of the ways to insert a new row in a table is by pressing ALT + Insert  + Arrow keys.

This does not work.

Steps to Reproduce:
1. Create a table.
2. Go to the last row.
3. Press ALT + Insert.
4. Press arrow down/up.

Actual Results:
Pressing the arrow down key would instead insert a newline.
Pressing the arrow up key would do nothing.

Expected Results:
Insert a new row either above or below depending on the arrow keys.


Reproducible: Always


User Profile Reset: No



Additional Info:
I realize I am not using the latest version of LibreOffice Writer, but this is the latest version in Ubuntu 18.04.1. So I am not sure what to do to fix it....I guess I could build from source if its been fixed already.
Comment 1 Dieter Praas 2018-12-17 20:43:35 UTC
I confirm this with

Version: 6.1.4.2 (x64)
Build-ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

and also

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL

but I'm not sure wether this is a bug within writer or within help

cc: Olivier Hallot
Comment 2 Xisco Faulí 2018-12-18 16:30:53 UTC
Same problem in


LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

so this is a documentation problem....
Comment 3 Hanif Bin Ariffin 2018-12-18 20:22:18 UTC
Hi,

I think I have found the problem. The documentation was vague on whether or not you have to hold press ALT + INSERT.

What you should do is press ALT + INSERT. Lift your hands and then press Up or Down key to insert the rows.

I guess the documentation did say "then" but I would argue that it is more intuitive to hold press instead of just press.
Comment 4 Dieter Praas 2018-12-18 20:30:30 UTC
(In reply to Hanif Bin Ariffin from comment #3)

> What you should do is press ALT + INSERT. Lift your hands and then press Up
> or Down key to insert the rows.

Doesn't work for me.
Comment 5 Regina Henschel 2018-12-18 21:05:46 UTC
It is a bug. The expected behavior is, that Alt+Insert switches for 3 seconds into insert mode where you can insert rows/columns by using the arrow keys. The cursor moves to the new row/column.
Similar switches Alt+Del to delete mode for 3 seconds. Now you can delete row/column by using the arrow keys.

It is OK in Version: 5.1.6.1
Build ID: f3e25ec0581f5012f54d8810dcddd5824f4ee374
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: de-DE (en_US); Calc: group

It is broken in Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
Comment 6 Hanif Bin Ariffin 2018-12-18 21:08:08 UTC
(In reply to Regina Henschel from comment #5)
> It is a bug. The expected behavior is, that Alt+Insert switches for 3
> seconds into insert mode where you can insert rows/columns by using the
> arrow keys. The cursor moves to the new row/column.
> Similar switches Alt+Del to delete mode for 3 seconds. Now you can delete
> row/column by using the arrow keys.
> 
> It is OK in Version: 5.1.6.1
> Build ID: f3e25ec0581f5012f54d8810dcddd5824f4ee374
> CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
> Locale: de-DE (en_US); Calc: group
> 
> It is broken in Version: 6.1.3.2 (x64)
> Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
> CPU threads: 8; OS: Windows 10.0; UI render: default; 
> Locale: de-DE (en_US); Calc: CL

I am using 

Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-CA (en_CA.UTF-8); Calc: group

And it works fine. Maybe 6.1 broke it?
Comment 7 Maxim Monastirsky 2018-12-18 21:24:53 UTC
That function no longer exists since 6.1, see Bug 116452.
Comment 8 Dieter Praas 2018-12-18 21:30:30 UTC
(In reply to Maxim Monastirsky from comment #7)
> That function no longer exists since 6.1, see Bug 116452.

=> I updated bug summary
Comment 9 Olivier Hallot 2019-04-11 22:24:24 UTC
Patch submitted

https://gerrit.libreoffice.org/#/c/70614/
Comment 10 Commit Notification 2019-04-15 13:16:48 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/2876d94eb8de71136de6239dd5387a79002a6acc%5E%21

tdf#122162 Keyboard shortcuts in table not valid
Comment 11 Xisco Faulí 2019-05-16 10:19:03 UTC
A polite ping to Olivier Hallot:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks