Bug 122166 - Print page layout fails on screen 4:3
Summary: Print page layout fails on screen 4:3
Status: RESOLVED DUPLICATE of bug 120242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2018-12-18 07:23 UTC by Patrik Eschle
Modified: 2019-01-24 11:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Print dialogue with 6 slides per page. Left: only 4 slides are printed with slide format Screen 4:3. Right: All 6 slides are printed with slide format A4 (252.97 KB, image/png)
2018-12-18 07:23 UTC, Patrik Eschle
Details
Impress document with 6 slides in format screen 4:3 (10.85 KB, application/vnd.oasis.opendocument.presentation)
2018-12-18 07:25 UTC, Patrik Eschle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrik Eschle 2018-12-18 07:23:37 UTC
Created attachment 147640 [details]
Print dialogue with 6 slides per page. Left: only 4 slides are printed with slide format Screen 4:3. Right: All 6 slides are printed with slide format A4

In Draw and Impress when printing "6 slides per page" only 4 are printed with slide format "screen 4:3 landscape".

The print page should be rotated to portrait mode to give room for all 6 slides.

This does not happen with slide format "A4 landscape".

To reproduce:
- open LibreOffice Draw or Impress
- set Slide / Properties to Format Screen 4:3, select Orientation Landscape
- Create 6 Slides, give them some content
- Open print dialogue with File / Print
- Select Tab Page Layout, select Pages per Sheet: 6

The print page remains in landscape mode, only 4 slides are visible
Comment 1 Patrik Eschle 2018-12-18 07:25:34 UTC
Created attachment 147641 [details]
Impress document with 6 slides in format screen 4:3
Comment 2 Durgapriyanka 2018-12-18 19:25:51 UTC
Thank you for reporting the bug. I can not reproduce the bug in 

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded


But, it is reproducible in 

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 3 Patrik Eschle 2018-12-18 20:50:08 UTC
I see it in 6.2

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF8); UI-Language: en-US
Calc: CL
Comment 4 Roman Kuznetsov 2018-12-21 07:50:50 UTC
(In reply to Durgapriyanka from comment #2)
> Thank you for reporting the bug. I can not reproduce the bug in 
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 3c964980da07892a02d5ac721d80558c459532d0
> CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
> TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
> Locale: en-US (en_US); UI-Language: en-US
> Calc: threaded
> 
> 
> But, it is reproducible in 
> 
> Version: 6.1.3.2
> Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
> CPU threads: 2; OS: Windows 6.1; UI render: default; 
> Locale: en-US (en_US); Calc: group threaded

In 6.3 Print dialogue was reworked
Comment 5 Xisco Faulí 2019-01-24 11:50:46 UTC
Not reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 0d46fb02f3f19d11db40b6c5335d78a3894502d7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

with the new print dialog...
Regarding 6.1 and 6.2, thi is a regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=57991f885e60d04e93bf5004d4fdceee7d29f3d8 which is already reported in bug 120242

*** This bug has been marked as a duplicate of bug 120242 ***