Bug 122193 - Rendering of the content in Writer is compromised after just scrolling a little on MacOS
Summary: Rendering of the content in Writer is compromised after just scrolling a litt...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-19 11:42 UTC by Fabio Frumento
Modified: 2018-12-19 14:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the result (786.51 KB, image/png)
2018-12-19 11:43 UTC, Fabio Frumento
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Frumento 2018-12-19 11:42:11 UTC
Description:
While working on a document scrolling it cause the content to be rendered completely fuzzy, please see attachment.

No matter if scrolling by trackpad, mouse wheel or scroll bars.

Steps to Reproduce:
1.Create a document
2.Fill with content
3.Scroll

Actual Results:
The content is rendered in a fuzzy way

Expected Results:
The content is rendered normally


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Fabio Frumento 2018-12-19 11:43:05 UTC
Created attachment 147667 [details]
Screenshot of the result
Comment 2 Xisco Faulí 2018-12-19 11:48:27 UTC
Hello Fabio Frumento,
Are you using LibreOffice Vanilla ? In that case, could you please update to Libreoffice Vanilla 6.1.3(5) and retest ?
Comment 3 Fabio Frumento 2018-12-19 11:53:27 UTC
Hi Xisco,

Yes I'm using Vanilla with just the Italian translation pack.

I've just downloaded 6.1.4 it's ok to test to it?
Comment 4 Xisco Faulí 2018-12-19 11:55:50 UTC
Just upgrade LibreOffice Vanilla. A new minor release was published today ( 6.1.3(5) ) -> https://itunes.apple.com/es/app/libreoffice-vanilla/id921923693?mt=12
Comment 5 Fabio Frumento 2018-12-19 14:14:49 UTC
OK,

First I want to clarify that I'm not using LibreOffice vanilla (App Store version) but the version downloaded from the main home site. I got confused because I was thinking of the "vanilla" as "without any plugin".

Then I did some more tests:

1) With version 6.1.3.2 without OpenGL the rendering bug is there

2) With version 6.1.3.2 with OpenGL enabled the rendering is ok also while scrolling.

3) I've switched to 6.1.4 and the bug is no more with or without OpenGL.

Hope this is useful in some manner.

thanks all for the support