Download it now!
Bug 122198 - The data source connected by "exchange database" is disconnected after the file is closed.
Summary: The data source connected by "exchange database" is disconnected after the fi...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, bisected, regression
: 117285 (view as bug list)
Depends on:
Blocks: Data-SourceView
  Show dependency treegraph
 
Reported: 2018-12-19 14:14 UTC by jun meguro
Modified: 2019-05-14 12:53 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jun meguro 2018-12-19 14:14:36 UTC
1.Open new odt document.
2.Edit > Exchange database.
3.Exchange database Dialog will open.
4.Browse > select any address(.odb or .ods) file.
5.Select table in file.
6.Click "define" and close dialog.
7.View > Data sources.
8.Make sure that the selected data source is listed.
9.Save and close document.
10.Re-open saved document.
11.View > Data sources.
12.The connection will be gone.
Comment 1 Dieter 2018-12-19 14:35:06 UTC
I confirm it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded


But not with

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 2 Xisco Faulí 2018-12-20 12:40:34 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=97477ee5e11951a5a25a91b89f1b71a1b78ac8f5

author	Szymon Kłos <szymon.klos@collabora.com>	2017-09-08 10:57:55 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-09-09 11:42:50 +0200
commit	97477ee5e11951a5a25a91b89f1b71a1b78ac8f5 (patch)
tree	77d49f492b37bc05ac9eafc77b7a7f28c31530ed
parent	a45800f010f3e063c6f31426fcdba76aa5b43d3e (diff)
tdf#108572 remove connections only for current shell

Bisected with: bibisect-win32-6.0

Adding Cc: to Szymon Kłos

it seems the problem is only reproduced the first time we do the connection between the .odt file and the .ods file. After the first crash, it no longer crashes. Thus, the user folder needs to be removed every time
Comment 3 Xisco Faulí 2019-01-07 11:13:30 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-01-07 11:15:16 UTC
*** Bug 117285 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-01-31 14:53:48 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a4ac1a93b540ae22dd317d88b5c3da8a7678db24%5E%21

tdf#122198 don't remove db after close

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-05-14 10:34:18 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 630db80d17616d635cf2e5f1d5a0852428b794a3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Szymon Kłos, thanks for fixing this issue! 

backported to https://gerrit.libreoffice.org/#/c/72277/
Comment 7 Commit Notification 2019-05-14 12:53:08 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3f408f8d848c191654cd3f2ead95975b3a3cc933%5E%21

tdf#122198 don't remove db after close

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.