Bug 122204 - FILEOPEN: ppt: old kind arc from MS Office 97 is wrongly imported
Summary: FILEOPEN: ppt: old kind arc from MS Office 97 is wrongly imported
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0.2 target:6.3.0
Keywords: bibisected, bisected, filter:ppt, regression
Depends on:
Blocks: PPT
  Show dependency treegraph
 
Reported: 2018-12-19 19:46 UTC by Regina Henschel
Modified: 2019-01-23 13:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Some examples of shape type "arc". (14.00 KB, application/vnd.ms-powerpoint)
2018-12-19 19:46 UTC, Regina Henschel
Details
collection of screenshots, how PowerPoint renders the arcs (249.56 KB, application/vnd.oasis.opendocument.presentation)
2018-12-19 19:47 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-12-19 19:46:24 UTC
Created attachment 147680 [details]
Some examples of shape type "arc".

Open attached file. Most arcs are distorted. It depends on the position of the handles, how much they are distorted.

The yellow shapes are not full ellipses, but the handles are very near to each other.

The second file contains a document with screenshots of the rendering in PowerPoint.
Comment 1 Regina Henschel 2018-12-19 19:47:36 UTC
Created attachment 147681 [details]
collection of screenshots, how PowerPoint renders the arcs
Comment 2 Regina Henschel 2018-12-19 20:18:59 UTC
It was OK in Version: 4.5.0.0.alpha0+
Build ID: 40b1e8266e47792d354cd457c652bfb0f0a21e69
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-11_00:13:43
Locale: en_US

Slide 4 is broken in Version: 5.1.6.1
Build ID: f3e25ec0581f5012f54d8810dcddd5824f4ee374
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: de-DE (en_US); Calc: group

All other shapes are OK till (including) Version: 6.2.0.0.alpha0+ (x64)
Build ID: 6baca63b44bf7f75a522b1adc4b4bbce502aec3b
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-20_01:35:41
Locale: en-US (en_US); Calc: threaded

It is totally broken in Version: 6.2.0.0.alpha1+ (x64)
Build ID: 5690acdb44e8017055bb88e86e19d207836bb95c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-27_02:59:30
Locale: de-DE (en_US); Calc: CL
Comment 3 Durgapriyanka 2018-12-20 16:17:56 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 raal 2018-12-22 08:30:32 UTC
Bisected "Slide 4 is broken in Version: 5.1.6.1"
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara; Could you possibly take a look at this one? Thanks

e5bb029cb0c17539bb5649b68ff07621586025a2 is the first bad commit
commit e5bb029cb0c17539bb5649b68ff07621586025a2
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jul 31 12:09:28 2015 -0700

    source sha:b3cd47bd562f98ec5fcff1a9d7609353506b5083

author	Caolán McNamara <caolanm@redhat.com>	2015-07-16 14:53:37 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2015-07-16 17:12:39 +0100
commit	b3cd47bd562f98ec5fcff1a9d7609353506b5083 (patch)
tree	19883694cdbff784dfb2d6fdf3015ba5b584dfd8
parent	33255f974fc712b9e9e2965a350c65a2195a7ae6 (diff)
Resolves: tdf#92772 missing shape bg color
Comment 5 raal 2018-12-22 16:36:25 UTC
Bisected "It is totally broken in Version: 6.2.0.0.alpha1+"

4069870cb6aa7797466cd22927efce09eb441d65 is the first bad commit
commit 4069870cb6aa7797466cd22927efce09eb441d65
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Oct 24 16:08:58 2018 -0700

    source sha:a8f0068fccfa3495ea8c7f1548a3cd4662bf391c
author	Caolán McNamara <caolanm@redhat.com>	2018-10-24 14:06:03 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-10-24 22:12:38 +0200
commit	a8f0068fccfa3495ea8c7f1548a3cd4662bf391c (patch)
tree	40275e67a63a9d9b10e75de902846bf96bcb6713
parent	cef587ce6c14261250623fe1d5e100f67952f4ca (diff)
ofz#11103 Integer-overflow
Comment 6 Commit Notification 2018-12-23 17:12:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/db5a8b6668be02325098d96d9e5351eaa06be24f%5E%21

tdf#122204 reversed checked_multiply check

It will be available in 6.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-12-23 17:12:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/41a36dc2bfc6a60baf3d93ffe16ccb3430cd87ae%5E%21

tdf#122204 reversed checked_multiply check

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2018-12-23 17:28:02 UTC
The 6.2.0.0 one is a clear regression at that identified commit, the other one is a bit hazy in that it looks like the broken case gave the right result (?), there might be a different regression/problem hidden in there
Comment 9 Commit Notification 2018-12-23 21:24:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/721bc6dafbed2185a9aedae35a34d3395eaed0bc%5E%21

Related: tdf#122204 clarify 0xFFF0 size meaning

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-01-23 12:27:18 UTC
A polite ping to Caolán McNamara:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 11 Regina Henschel 2019-01-23 13:29:13 UTC
The shape on slide 4 is still broken in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 6d70e04f66cbeb3aeeb1e9b69d5b201ae3d24747
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-19_23:55:14
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

The other shapes are OK now.
Comment 12 Xisco Faulí 2019-01-23 13:39:21 UTC
(In reply to Regina Henschel from comment #11)
> The shape on slide 4 is still broken in Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 6d70e04f66cbeb3aeeb1e9b69d5b201ae3d24747
> CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-19_23:55:14
> Locale: de-DE (en_US); UI-Language: en-US
> Calc: threaded
> 
> The other shapes are OK now.

Ok, let's then close it as VERIFIED FIXED and I'll create a follow-up for the shape in slide 4