Download it now!
Bug 122223 - Document recovery dialog is not visible in the task bar
Summary: Document recovery dialog is not visible in the task bar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-20 12:50 UTC by rwman
Modified: 2019-03-21 12:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rwman 2018-12-20 12:50:53 UTC
On linux, when user starts Libreoffice, it is supposed to see the document recovery dialog first. But that dialog is not visible due two issues: 1) It is opened in the background, below all other opened apps. (another issue) 2) It is absent in the task bar (task manager in KDE). 

This makes user think that Libreoffice won't start at all, and it tries again and again. There are two odd ways user can discover that LO did start: 1) Minimize all opened application windows 2) Hit Alt+Tab and click on that recovery dialog to open above other windows.

OS: openSUSE linux
Desktop environment: KDE5
Comment 1 Michael Weghorn 2019-01-21 22:07:30 UTC
Thanks for your bug report.

(In reply to rwman from comment #0)
> On linux, when user starts Libreoffice, it is supposed to see the document
> recovery dialog first. But that dialog is not visible due two issues: 1) It
> is opened in the background, below all other opened apps. (another issue)

This may be unrelated to LibreOffice itself, but related to KDE Plasma, which often opens other windows in the background by default. You can possibly adapt this in the System Settings (somewhere in "Window Management" -> "Window Behaviour").
For me, it opened in the foreground (using KDE Plasma on Debian testing).

2)
> It is absent in the task bar (task manager in KDE). 

Can you please paste the version information in "Help" -> "About LibreOffice"?

Whether the entry appears in the task manager seems to depend on the VCL plugin being used. With the current development version of LibreOffice, the entry appears for me with 

Version: 6.3.0.0.alpha0+
Build ID: fef58ec13c548fbd692adabafb0a84f50c273146
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-21_04:32:52
Locale: en-US (en_DK.UTF-8); UI-Language: en-US
Calc: threaded

but not when using the gtk3 VCL plugin:

Version: 6.3.0.0.alpha0+
Build ID: fef58ec13c548fbd692adabafb0a84f50c273146
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-21_04:32:52
Locale: en-US (en_DK.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Michael Weghorn 2019-01-21 22:12:14 UTC
(In reply to Michael Weghorn from comment #1)
> Whether the entry appears in the task manager seems to depend on the VCL
> plugin being used. [...]

The behaviour is the same for the Database Wizard, by the way, i.e. when staring LibreOffice with

  SAL_USE_VCLPLUGIN=kde5 ./opt/libreofficedev6.3/program/soffice --base

as compared to

  SAL_USE_VCLPLUGIN=gtk3 ./opt/libreofficedev6.3/program/soffice --base

I'm not sure what the intended behaviour is.
Comment 3 rwman 2019-01-22 14:57:48 UTC
> Can you please paste the version information in "Help" -> "About LibreOffice"?

Version: 6.1.4.2
Build ID: 10(Build:2)
CPU threads: 2; OS: Linux 4.20; UI render: default; VCL: gtk3_kde5; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

> but not when using the gtk3 VCL plugin

Both variants below show the recovery dialog, and does not show any entry in the taskbar:
SAL_USE_VCLPLUGIN=gtk3 libreoffice --base
SAL_USE_VCLPLUGIN=kde5 libreoffice --base
Comment 4 Michael Weghorn 2019-01-22 18:57:23 UTC
Thanks!

(In reply to rwman from comment #3)
> Both variants below show the recovery dialog, and does not show any entry in
> the taskbar:
> SAL_USE_VCLPLUGIN=gtk3 libreoffice --base
> SAL_USE_VCLPLUGIN=kde5 libreoffice --base

kde5 is only available from LibreOffice 6.2 on and according to your version information, you're using 6.1; so I suppose that for the second case the environment variable was just ignored and you probably still had gtk3_kde5 in use - which would explain why your observations differ from mine. Please correct me if I'm wrong. (You can verify by looking at the "VCL:" entry in the version information which VCL plugin is actually used.)
Comment 5 Xisco Faulí 2019-01-23 12:29:25 UTC
Hello rwman,
Could you please try it with LibreOffice 6.2.0.2 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
Comment 6 rwman 2019-01-23 13:16:33 UTC
> Could you please try it with LibreOffice 6.2.0.2 from 
> https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?

That page is currently broken, so i installed version 6.2.0.2 from opensuse unstable libreoffice repo

Version: 6.2.0.2
Build ID: 20(Build:2)
CPU threads: 2; OS: Linux 4.20; UI render: default; VCL: gtk3_kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Results are the same: Both variants below show the recovery dialog, and does not show any entry in the taskbar:
SAL_USE_VCLPLUGIN=gtk3 libreoffice --base
SAL_USE_VCLPLUGIN=kde5 libreoffice --base

And both variants report "VCL: gtk3_kde5;" in the "help" -> "about libreoffice"
Comment 7 Michael Weghorn 2019-01-23 15:47:24 UTC
(In reply to rwman from comment #6)
> > Could you please try it with LibreOffice 6.2.0.2 from 
> > https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
> 
> That page is currently broken, so i installed version 6.2.0.2 from opensuse
> unstable libreoffice repo

The page looks OK for me, at least now. Can you possibly try again? Alternatively, you can also use the daily builds provided at https://dev-builds.libreoffice.org/daily/ .

> ...
> And both variants report "VCL: gtk3_kde5;" in the "help" -> "about
> libreoffice"

... in which case gtk3 and kde5 were not actually used. I guess that either OpenSUSE does not package them or you need to install additional packages to get those VCL plugins as well.
Comment 8 rwman 2019-01-23 19:29:16 UTC
Oh, just installed it from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases and now i can see the document recovery window in the taskbar, when started with 

  SAL_USE_VCLPLUGIN=kde5 ./opt/libreofficedev6.3/program/soffice --writer

But not

  SAL_USE_VCLPLUGIN=gtk3 ./opt/libreofficedev6.3/program/soffice --writer

But the window icon in the taskbar is default "X" icon, not the proper libreoffice one. Is it related to these messages i got when installed from the rpm files?

    mkdir: cannot create directory ‘/usr/share/icons/hicolor/icon-theme.cache’: Not a directory
    mkdir: cannot create directory ‘/usr/share/icons/hicolor/index.theme’: Not a directory

These are indeed regular files, not directories.
Should i create new issue for the missing icons?
Comment 9 Michael Weghorn 2019-01-23 22:12:40 UTC
Thanks for testing.

(In reply to rwman from comment #8)
> But the window icon in the taskbar is default "X" icon, not the proper
> libreoffice one. Is it related to these messages i got when installed from
> the rpm files?
> 
>     mkdir: cannot create directory
> ‘/usr/share/icons/hicolor/icon-theme.cache’: Not a directory
>     mkdir: cannot create directory ‘/usr/share/icons/hicolor/index.theme’:
> Not a directory

I can't say right away.

> These are indeed regular files, not directories.
> Should i create new issue for the missing icons?

Yes, please do.
Comment 10 Xisco Faulí 2019-03-21 12:28:05 UTC
(In reply to rwman from comment #8)
> Oh, just installed it from
> https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases and now
> i can see the document recovery window in the taskbar, when started with 
> 
>   SAL_USE_VCLPLUGIN=kde5 ./opt/libreofficedev6.3/program/soffice --writer
> 
> But not
> 
>   SAL_USE_VCLPLUGIN=gtk3 ./opt/libreofficedev6.3/program/soffice --writer
> 

Since this report is about KDE5 and the problem is no longer reproducible, let's close this issue as RESOLVED WORKSFORME.
Please, report a new issue for GTK3

> But the window icon in the taskbar is default "X" icon, not the proper
> libreoffice one. Is it related to these messages i got when installed from
> the rpm files?
> 
>     mkdir: cannot create directory
> ‘/usr/share/icons/hicolor/icon-theme.cache’: Not a directory
>     mkdir: cannot create directory ‘/usr/share/icons/hicolor/index.theme’:
> Not a directory
> 
> These are indeed regular files, not directories.
> Should i create new issue for the missing icons?

it was reported in bug 104235 and it's fixed in LibreOffice 6.2.3.