Bug 122225 - FILEOPEN DOCX Textbox of Column chart legend reduces and text of legend disappears
Summary: FILEOPEN DOCX Textbox of Column chart legend reduces and text of legend disap...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
: 119953 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2018-12-20 12:57 UTC by NISZ LibreOffice Team
Modified: 2020-06-30 12:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Microsoft Word 2013 and LibreOffice Writer 6.1.4.1. (162.22 KB, image/png)
2018-12-20 12:58 UTC, NISZ LibreOffice Team
Details
creenshot of the original document side by side in LibreOffice Writer 6.1.4.1. and LibreOffice Writer 6.3.0.0.alpha0+. (145.75 KB, image/png)
2018-12-20 12:58 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Microsoft Word 2013 and LibreOffice Writer 6.3.0.0.alpha0+. (119.76 KB, image/png)
2018-12-20 12:58 UTC, NISZ LibreOffice Team
Details
Example file from Word (49.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-20 13:00 UTC, NISZ LibreOffice Team
Details
Screenshot on fresh master (42.26 KB, image/png)
2019-01-30 08:26 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-20 12:57:43 UTC
Description:
Textbox of column chart legend in DOCX documents created with Microsoft Word reduces and text of legend disappears when the document is opened in LibreOffice Writer 6.3.0.0.alpha0+.

Steps to Reproduce:
    1. Open the attached DOCX file in LibreOffice Writer.
    2. Open a copy in Microsoft Word.
    3. Compare the original file opened in Writer and Word.
    4. View the attached screenshot.
    5. Notice, that Textbox of Column chart legend reduces and text of legend disappears

Actual Results:
Textbox of Column chart legend reduces and text of legend disappears when the document is opened in LibreOffice Writer 6.3.0.0.alpha0+.

Expected Results:
Textbox of Column chart legend should have the same size and content as the original file when the document is opened in Microsoft Word 2010.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-20 12:58:11 UTC
Created attachment 147701 [details]
Screenshot of the original document side by side in Microsoft Word 2013 and LibreOffice Writer 6.1.4.1.
Comment 2 NISZ LibreOffice Team 2018-12-20 12:58:31 UTC
Created attachment 147702 [details]
creenshot of the original document side by side in LibreOffice Writer 6.1.4.1. and LibreOffice Writer 6.3.0.0.alpha0+.
Comment 3 NISZ LibreOffice Team 2018-12-20 12:58:55 UTC
Created attachment 147703 [details]
Screenshot of the original document side by side in Microsoft Word 2013 and LibreOffice Writer 6.3.0.0.alpha0+.
Comment 4 NISZ LibreOffice Team 2018-12-20 13:00:21 UTC
Created attachment 147704 [details]
Example file from Word
Comment 5 Dieter 2018-12-20 13:28:56 UTC
I confirm it with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2019-01-09 15:46:07 UTC
I can't reproduce the problematic behaviour in

Version: 6.3.0.0.alpha0+
Build ID: 54515a6a01a372729bf8a7f9e992c51f214ec9a6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

what I do:
1. Select the chart
2. Click on legend
3. Position -> Top

and the legend is displayed correctly.
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 7 Xisco Faulí 2019-01-14 10:15:23 UTC Comment hidden (obsolete)
Comment 8 Gabor Kelemen 2019-01-14 10:30:30 UTC
(In reply to Xisco Faulí from comment #7)
> @NISZ LibreOffice Team, see comment 6

I'll look into this, so far rather strange:
- I see it in bibisect-win32-6.1 latest version
- I don't see it in bibisect-win32-6.2 earliest version, nor in 6.3. Bibisecting does not show when was it fixed/ did it disappear (maybe I took a wrong turn).
- I see it on current(-ish) master on Ubuntu 18.04

So far inconclusive, investigating...

Also you really want to check is the legend box size, with F4 key, not the alignment itself; the first attachment is irrelevant here, the second is relevant.
Comment 9 Gabor Kelemen 2019-01-30 08:26:11 UTC
Created attachment 148746 [details]
Screenshot on fresh master

I see this in 6.3 master on Win 8.1:
Also with earlier 6.3 versions from bibisect-win32-6.3 - not sure why did I wrote that I can't see it anymore :(.

Version: 6.3.0.0.alpha0+
Build ID: fcc5fc76c33de566cb2d02be541dcbde29d1eb8a
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 10 Gabor Kelemen 2019-02-11 14:41:45 UTC
Also: not an OLE-problem but OOXML chart
Comment 11 Timur 2019-04-30 13:06:33 UTC
Repro 6.3+. 
Font in MSO is Cambria 18. Font in LO is Cambria 21,6. 
I can't see legend box size in MSO, but size in LO is 5,85x1,01 cm. And that's not enough, because even with font 18 contents cannot be seen.
Comment 12 Commit Notification 2020-06-29 08:49:27 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8c73d6b63714fb41486fd53ec4c7f68ad63cd190

tdf#122225 Chart OOXML import: fix missing legend text

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Tünde Tóth 2020-06-29 13:07:19 UTC
*** Bug 119953 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-06-30 12:38:15 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/936259e7965857541a9ec02db1eebd966718beb4

tdf#122225 Chart OOXML import: fix missing legend text

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.