Download it now!
Bug 122236 - KDE5: too large gaps between radiobutton and text (if there is no icon for the item)
Summary: KDE5: too large gaps between radiobutton and text (if there is no icon for th...
Status: VERIFIED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-21 08:29 UTC by Vera Blagoveschenskaya
Modified: 2019-03-22 11:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
view-kde5 (162.92 KB, image/png)
2018-12-21 08:29 UTC, Vera Blagoveschenskaya
Details
view-gtk3 (160.67 KB, image/png)
2018-12-21 08:30 UTC, Vera Blagoveschenskaya
Details
122236-6.1.5.2-view.png (65.83 KB, image/png)
2019-02-08 06:30 UTC, Vera Blagoveschenskaya
Details
122236-6.3.0.0-view.png (68.40 KB, image/png)
2019-02-08 06:30 UTC, Vera Blagoveschenskaya
Details
qt4-menu.png (13.20 KB, image/png)
2019-02-11 08:00 UTC, Aleksei Nikiforov
Details
qt5-menu.png (13.28 KB, image/png)
2019-02-11 08:01 UTC, Aleksei Nikiforov
Details
qt-menu-icons.tar.bz2 (1.85 KB, application/x-bzip)
2019-02-11 08:07 UTC, Aleksei Nikiforov
Details
another-app (21.46 KB, image/png)
2019-03-22 06:39 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-12-21 08:29:22 UTC
Description:
KDE5: too large gaps between radiobutton and text (if there is no icon for the item)


Steps to Reproduce:
1. Start LO with SAL_USE_VCLPLUGIN=gtk3
2. Start LO with SAL_USE_VCLPLUGIN=kde5
3. Check the difference between view of submenus with checkbox/radiobuttons (for example, look at Styles menu)

Actual Results:
For kde5: too large gaps between radiobutton and text (if there is no icon for the item)

Look at the screens

Expected Results:
Remove gaps


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

DO not reproduced for
Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-12-21 08:29:54 UTC
Created attachment 147731 [details]
view-kde5
Comment 2 Vera Blagoveschenskaya 2018-12-21 08:30:10 UTC
Created attachment 147732 [details]
view-gtk3
Comment 3 Xisco Faulí 2018-12-21 11:54:08 UTC
I can't reproduce it in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Vera Blagoveschenskaya 2018-12-21 13:18:00 UTC
(In reply to Xisco Faulí from comment #3)

> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?

I removed 
/home/<user name>/.config/libreoffice/4/user  
and restart LO

Issue is still present
Comment 5 Xisco Faulí 2019-02-07 20:47:24 UTC
Hi Vera,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 Vera Blagoveschenskaya 2019-02-08 06:29:53 UTC
Hello Xisco,

view of the menu is better in

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded

large gaps are still presented in

Version: 6.3.0.0.alpha0+
Build ID: 51af3179cf972809d6495c7d58033e069f647bbf
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Please look at the screenshots below.
Comment 7 Vera Blagoveschenskaya 2019-02-08 06:30:21 UTC
Created attachment 149008 [details]
122236-6.1.5.2-view.png
Comment 8 Vera Blagoveschenskaya 2019-02-08 06:30:44 UTC
Created attachment 149009 [details]
122236-6.3.0.0-view.png
Comment 9 Aleksei Nikiforov 2019-02-11 08:00:36 UTC
Created attachment 149075 [details]
qt4-menu.png

A screenshot of menu from example Qt application built with Qt4.
Comment 10 Aleksei Nikiforov 2019-02-11 08:01:08 UTC
Created attachment 149076 [details]
qt5-menu.png

A screenshot of menu from example Qt application built with Qt5.
Comment 11 Aleksei Nikiforov 2019-02-11 08:07:05 UTC
Created attachment 149077 [details]
qt-menu-icons.tar.bz2

Sources of sample Qt application.

If no icons are visible, it may be required to change hardcoded "desktop" icon name in mainwindow.ui.

I've attached screenshots of same application built with Qt4 and Qt5. To me it looks like it's either an issue in upstream Qt5 or an intended design change.
Comment 12 Xisco Faulí 2019-03-21 12:11:34 UTC
looking at the screenshot provided by Vera, it seems it takes one column for the checkbuttons and another for the icons while in KDE4 both are in the same column... Same in Aleksei's screenshots. It looks like it's the way KDE5 draws the menus.
@Vera, could you please check with another app in KDE5 ?
Comment 13 Vera Blagoveschenskaya 2019-03-22 06:38:52 UTC
(In reply to Xisco Faulí from comment #12)
> looking at the screenshot provided by Vera, it seems it takes one column for
> the checkbuttons and another for the icons while in KDE4 both are in the
> same column... Same in Aleksei's screenshots. It looks like it's the way
> KDE5 draws the menus.
> @Vera, could you please check with another app in KDE5 ?

Please look at the screen for another application.
Seems, we should close the bug as notourbug?
Comment 14 Vera Blagoveschenskaya 2019-03-22 06:39:41 UTC
Created attachment 150168 [details]
another-app
Comment 15 Xisco Faulí 2019-03-22 09:07:19 UTC
Hello Vera,
thanks for providing the screenshot. Indeed, it looks like it's the way KDE5 draw menus.
Closing as RESOLVED NOTABUG
Comment 16 Vera Blagoveschenskaya 2019-03-22 11:36:03 UTC
It's not bug, it's a feature ;-)