Bug 122243 - LO62rc1: On macOS after opening or creating a document Writer becomes unresponsive
Summary: LO62rc1: On macOS after opening or creating a document Writer becomes unrespo...
Status: RESOLVED DUPLICATE of bug 121778
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-21 10:30 UTC by Martin Srebotnjak
Modified: 2019-03-03 12:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-12-21 10:30:07 UTC
Description:
Working on a document and then closing it should close all open windows on the desktop; but since b2 (or b1?) it seems that after closing the last opened document its window persists (although all menus of LO go back to the state when no document is opened and only the LO is started).

Steps to Reproduce:
1. Open a document
2. Close the document
3.

Actual Results:
Document's window does not close.

Expected Results:
Should close.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-12-21 11:38:30 UTC

Thanks for reporting this issue.
Seems like a duplicate of bug 121778. We're working on it...

*** This bug has been marked as a duplicate of bug 121778 ***
Comment 2 Xisco Faulí 2018-12-22 10:35:20 UTC
Hello Martin,
Could you please download it again from https://dev-builds.libreoffice.org/pre-releases/mac/x86_64/xcode9/LibreOffice_6.2.0.1_MacOS_x86-64.dmg and retest? it should be fine now...
Comment 3 Martin Srebotnjak 2018-12-22 13:45:48 UTC
Seems to work ok!
Also, lang pack can be applied over it, so I suggest replacing the rc1 in the main folder with this one ...
Comment 4 Martin Srebotnjak 2018-12-25 12:39:55 UTC
Actually, this still happens. If I open two documents, then close one by one, there is still the first-closed window shown even if both windows get closed and the menu shows only the commnands for Start Center.

Please do re-open this as a separate bug and try to reproduce.
Comment 5 Martin Srebotnjak 2019-01-03 09:39:40 UTC
It still happens, it was not solved by solving bug 121778.
Reopening.
Comment 6 Xisco Faulí 2019-01-09 15:53:07 UTC
(In reply to Martin Srebotnjak from comment #5)
> It still happens, it was not solved by solving bug 121778.
> Reopening.

ok, then let put it back to UNCONFIRMED until someone confirms it...
Comment 7 Martin Srebotnjak 2019-01-12 09:41:05 UTC
This bug is actually more problematic.

After opening a document you cannot do anything with it (cannot edit it or operations execute very slowly, like repositioning of a cursor takes a minute).
Also, you cannot swith user interface - from notebookbar to something else.

I do not have additional extensions installed.
Comment 8 Martin Srebotnjak 2019-01-12 10:06:14 UTC
Happens with RC2 as well.
Comment 9 Martin Srebotnjak 2019-01-13 10:53:00 UTC
This might also be a duplicate of:
https://bugs.documentfoundation.org/show_bug.cgi?id=121778
It seems it is not limited to Writer.
Comment 10 cpohle 2019-01-14 10:34:14 UTC
(In reply to Martin Srebotnjak from comment #8)
> Happens with RC2 as well.

Confirm this bug is still present in Version: 6.2.0.2

Build-ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU-Threads: 4; BS: Mac OS X 10.14.2; UI-Render: GL; VCL: osx;
Comment 11 Xisco Faulí 2019-01-14 10:37:32 UTC
(In reply to Martin Srebotnjak from comment #9)
> This might also be a duplicate of:
> https://bugs.documentfoundation.org/show_bug.cgi?id=121778
> It seems it is not limited to Writer.

Well, I close it as a duplicate of bug 121778 in the first place and you revert my change. Why did you do that?
Comment 12 steve -_- 2019-03-03 12:50:38 UTC

*** This bug has been marked as a duplicate of bug 121778 ***