Download it now!
Bug 122251 - FILEOPEN hybrid PDF not recognised when opened from CIFS share
Summary: FILEOPEN hybrid PDF not recognised when opened from CIFS share
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2018-12-21 11:57 UTC by Lionel Elie Mamane
Modified: 2020-02-28 02:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
hybrid PDF - Calc (19.89 KB, application/pdf)
2019-01-21 14:45 UTC, Lionel Elie Mamane
Details
hybrid PDF - Writer (20.80 KB, application/pdf)
2019-01-21 14:45 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2018-12-21 11:57:46 UTC
Description:
A hybrid PDF containing an OpenDocument Text or Spreadsheet embedded opens as a regular PDF (in Draw) when opened from a CIFS share mounted from a Microsoft Windows Server on a GNU/Linux machine.
The exact same file, byte for byte, opens correctly in Writer or Calc, respectively, when opened from a local filesystem (ext4).

Steps to Reproduce:
1. Open hybrid PDF


Actual Results:
Opens in Draw as a normal PDF

Expected Results:
Opens in the LibreOffice component appropriate for the kind of OpenDocument embedded in the PDF.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Debian GNU/Linux
kernel 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux
CIFS mount options: rw,relatime,vers=2.1,sec=ntlmssp,cache=strict,username=USERNAME,domain=DOMAIN,uid=UID,forceuid,gid=GID,forcegid,addr=IPV4ADDRESS,file_mode=0600,dir_mode=0700,nounix,serverino,mapposix,rsize=1048576,wsize=1048576,echo_interval=60,actimeo=1,user=USERNAME

Version: 6.1.3.2
Build ID: 1:6.1.3-1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 

Dunno if OpenGL is enabled, there is no such checkbox in tools/options/libreoffice/view. The "use hardware rendering" checkbox is checked. Probably not relevant to current bug, but the bug report wizard asks...
$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 2.49.0 / 4.9.0-8-amd64, LLVM 3.9.1)
OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
Comment 1 Xisco Faulí 2019-01-21 14:26:53 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Lionel Elie Mamane 2019-01-21 14:45:21 UTC
Created attachment 148477 [details]
hybrid PDF - Calc
Comment 3 Lionel Elie Mamane 2019-01-21 14:45:42 UTC
Created attachment 148478 [details]
hybrid PDF - Writer
Comment 4 Lionel Elie Mamane 2019-01-21 14:47:11 UTC
Hybrid PDFs provided. Created from empty documents. (So. yes, they show blank pages in a PDF viewer, that's normal.)
Comment 5 Xisco Faulí 2019-07-31 11:38:44 UTC
Hi Lionel,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 QA Administrators 2020-01-28 03:28:23 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2020-02-28 02:50:17 UTC
Dear Lionel Elie Mamane,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp