Download it now!
Bug 122252 - Can't type accented Greek letters using KDE
Summary: Can't type accented Greek letters using KDE
Status: RESOLVED DUPLICATE of bug 121161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-21 12:14 UTC by Kriton Kyrimis
Modified: 2018-12-30 12:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kriton Kyrimis 2018-12-21 12:14:15 UTC
After upgrading to 6.2.0.1, I can no longer type accented Greek letters (e.g., by typing ;a to get ά) when using the KDE UI. (Pasting works fine, so you'll have to install a Greek keyboard to test.) The problem does not exist if I use the gnome UI.
Comment 1 Ioannis Ilousis-Iliadis 2018-12-23 19:59:18 UTC
Workaround is to remove package 'libobasis6.2-kde-integration'
Comment 2 Xisco Faulí 2018-12-26 16:06:34 UTC
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 3 Kriton Kyrimis 2018-12-26 16:57:40 UTC
Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: el-GR (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2018-12-27 09:44:48 UTC
Hi jan-marek,
is it related to bug 121161 ?
Comment 5 Jan-Marek Glogowski 2018-12-27 18:42:36 UTC
(In reply to Xisco Faulí from comment #4)
> Hi jan-marek,
> is it related to bug 121161 ?

Don't know. But I looked up the Greek layout, saw that ; is the ö on my German keyboard, switched my keyboard to gr and it "works for me".

So my guess would be it's a duplicate. Would be nice if the reporter could verify it's fixed for him.

*** This bug has been marked as a duplicate of bug 121161 ***
Comment 6 Kriton Kyrimis 2018-12-27 20:21:18 UTC
> So my guess would be it's a duplicate. Would be nice if the reporter could
> verify it's fixed for him.

I just tried the 6-2~2018-12-27_12.36.32 nightly and, indeed, the problem is fixed.
Comment 7 Ioannis Ilousis-Iliadis 2018-12-30 12:45:55 UTC
(In reply to Jan-Marek Glogowski from comment #5)
> (In reply to Xisco Faulí from comment #4)
> > Hi jan-marek,
> > is it related to bug 121161 ?
> 
> Don't know. But I looked up the Greek layout, saw that ; is the ö on my
> German keyboard, switched my keyboard to gr and it "works for me".
> 
> So my guess would be it's a duplicate. Would be nice if the reporter could
> verify it's fixed for him.
> 
> *** This bug has been marked as a duplicate of bug 121161 ***

Also it is fixed for me. I tried libreoffice-6-2_2018-12-30_03.08.52