Bug Hunting Session
Bug 122253 - KDE5: Crash closing full screen mode
Summary: KDE5: Crash closing full screen mode
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Aleksei Nikiforov
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: bibisectRequest, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-12-21 12:21 UTC by Xisco Faulí
Modified: 2019-01-14 15:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB backtrace (29.14 KB, text/x-log)
2018-12-21 19:30 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-12-21 12:21:28 UTC
Steps to reproduce:
1. Open writer
2. Go to Full screen ( Ctrl + Shift + J )
3. Click on Full Screen button

Reproduced in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2018-12-21 12:22:36 UTC
no crash with gtk3 nor kde4
Comment 2 Xisco Faulí 2018-12-21 12:27:21 UTC
not reproduced with beta1 -> regression...
Comment 3 Michael Weghorn 2018-12-21 19:29:59 UTC
Also reproducible on current master:

Version: 6.3.0.0.alpha0+
Build ID: 5df6e8e399a1634c7e8dfe3558fc8fcdac3fcb09
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Michael Weghorn 2018-12-21 19:30:28 UTC
Created attachment 147766 [details]
GDB backtrace
Comment 5 Commit Notification 2019-01-11 13:48:17 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c278857137ea0e9e25613d5f6bf8ddaf1336fbcc%5E%21

tdf#122253 KDE5: Correct parent menu before it's used

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-01-14 06:55:14 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b6704c14ce2241e76904e494125a520814ec5021%5E%21

tdf#122253 KDE5: Correct parent menu before it's used

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Weghorn 2019-01-14 10:38:10 UTC
No longer crashes with

Version: 6.3.0.0.alpha0+
Build ID: de63114d76433b5a1f1ed0286e28545c72330630
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

(The window still doesn't have the correct size afterwards, but that's handled in bug 120791).

@Aleksei: Is there anything else to be done as part of this bug report? Otherwise, feel free to close as RESOLVED FIXED (or RESOLVED VERIFIED, since I also tested).
Comment 8 Michael Weghorn 2019-01-14 10:47:01 UTC
(In reply to Michael Weghorn from comment #7)
> [...] (or RESOLVED VERIFIED, since > I also tested).

I mean VERIFIED FIXED of course...
Comment 9 Xisco Faulí 2019-01-14 10:50:00 UTC
(In reply to Michael Weghorn from comment #8)
> (In reply to Michael Weghorn from comment #7)
> > [...] (or RESOLVED VERIFIED, since > I also tested).
> 
> I mean VERIFIED FIXED of course...

Cherry-picked to 6-2-0 -> https://gerrit.libreoffice.org/#/c/66173/
Comment 10 Aleksei Nikiforov 2019-01-14 11:05:17 UTC
(In reply to Michael Weghorn from comment #7)
> @Aleksei: Is there anything else to be done as part of this bug report?
> Otherwise, feel free to close as RESOLVED FIXED (or RESOLVED VERIFIED, since
> I also tested).

I think I finished working on this bug. I'm working on some additional changes, but they may be posted separately. I can't set it to "VERIFIED FIXED", thus I'm setting it to "RESOLVED FIXED".
Comment 11 Commit Notification 2019-01-14 11:35:08 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/561f0d496666a3ad481eefc24cf94b44ce10bdad%5E%21

tdf#122253 KDE5: Correct parent menu before it's used

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.