Bug 122268 - FILEOPEN RTF: check box not corrected viewed on RTF file
Summary: FILEOPEN RTF: check box not corrected viewed on RTF file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: Form-Controls RTF-Tables
  Show dependency treegraph
 
Reported: 2018-12-21 16:44 UTC by paolo busto
Modified: 2018-12-22 07:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
rtf file + as i viwe in msword + libreoffice version (315.48 KB, application/x-zip-compressed)
2018-12-21 16:44 UTC, paolo busto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paolo busto 2018-12-21 16:44:26 UTC
Created attachment 147761 [details]
rtf file + as i viwe in msword + libreoffice version

hello
I've a problem with an RTF file create with ms word.

depending on LO version i'm using, sometimes the check box are not visible, or all are marked or all areNOT marked.

also, there is a text in a table where first chars are 'upper', so second line was not visible,

attached here the original file, as I view in msword and a different view depending by libreoffice version.

thnak you for your understanding
paolo
Comment 1 Roman Kuznetsov 2018-12-21 20:45:46 UTC
please in the future create different bugs for different problems (one for form controls and another for text in RTF table)
Comment 2 Dieter 2018-12-22 05:20:47 UTC
(In reply to paolo busto from comment #0)
> depending on LO version i'm using, sometimes the check box are not visible,
> or all are marked or all areNOT marked.

I can't confirm it with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded


It's not clear, in which versions of LO do you have the problem. Please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.

Please open a second report for yur second problem
Comment 3 paolo busto 2018-12-22 06:33:45 UTC
From version 5 2 x check box are visible and was correctly marked.
So, probably we can close this bug fix and working on the other, where lines in table aren't displayed correctly.
Comment 4 raal 2018-12-22 07:16:35 UTC
(In reply to paolo busto from comment #3)
> From version 5 2 x check box are visible and was correctly marked.
> So, probably we can close this bug fix and working on the other, where lines
> in table aren't displayed correctly.

Closing