Bug 122287 - Window menu items (i.e. File, Edit, View, Insert, etc.) show twice in Window title bar in Ubuntu global menu
Summary: Window menu items (i.e. File, Edit, View, Insert, etc.) show twice in Window ...
Status: RESOLVED DUPLICATE of bug 124391
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://wiki.gnome.org/Design/Playgro...
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-12-23 06:13 UTC by minutemeter
Modified: 2019-10-09 10:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of LibreOffice Writer (Repeated menu items are inside red rectangle) (481.06 KB, image/jpeg)
2018-12-23 06:26 UTC, minutemeter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description minutemeter 2018-12-23 06:13:06 UTC
Description:
Window menu items (i.e. File, Edit, View, Insert, etc.) show twice in Window title bar

Steps to Reproduce:
1. Just Run LibreOffice 6.2.0.1
2. Hover the mouse cursor over the window title bar
3. You will notice that the menu items show twice in the window title bar.

Actual Results:
You will notice that the menu items show twice in the window title bar. (e.g. File, Edit, View, etc. followed by another File, Edit, View, ...)

Expected Results:
Menu items in the Window title should only show once.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 minutemeter 2018-12-23 06:26:43 UTC
Created attachment 147781 [details]
Screenshot of LibreOffice Writer (Repeated menu items are inside red rectangle)
Comment 2 Roman Kuznetsov 2018-12-23 19:33:55 UTC
I think it's Ubuntu global menu problem, but I'll add to "Blocks" GTK3 label just in case

I can't repro this in LO 6.2.0.1 in Xubuntu 17.10 (64 bit). There isn't global menu there of course
Comment 3 Caolán McNamara 2018-12-23 19:50:41 UTC
I wonder if its the unity one plus our own, or two of our own. Which Ubuntu version is this happening under ?
Comment 4 Timur 2018-12-24 12:51:38 UTC
Please explain how you installed global menu and what is your Gnome version.
Also please write how you installed LO 6.2.0.
Comment 5 Timur 2018-12-24 13:42:02 UTC
From what I see, global menu is not officially supported in Ubuntu. 
So in my view this could be WontFix.
Comment 6 minutemeter 2018-12-25 06:24:10 UTC
Operating System: Ubuntu 16.04 LTS

Download 
Use a package unpacking program (e.g. Archive Manager, a.k.a. file-roller) to extract files to the home folder, e.g. /home/johndoe/
If you have any previous version of LibreOffice or OpenOffice, completely uninstall it first.
Next open a Terminal (Ctrl-Alt-T). In the Terminal, type
sudo dpkg -i /home/<username>/LibreOffice_6.2.0.1_Linux_x86-64_deb/DEBS/*.deb
to install LibreOffice, where <username> is your assigned login name, e.g. "johndoe"
Comment 7 Xisco Faulí 2019-01-17 11:57:58 UTC
Could you please try with LibreOffice 6.2.0.2 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
Comment 8 Buovjaga 2019-02-24 09:32:28 UTC
*** Bug 123675 has been marked as a duplicate of this bug. ***
Comment 9 trmdi 2019-03-08 17:56:12 UTC
This bug has gone in LO-6.2.1.2 / openSUSE Tumbleweed.
Comment 10 Xisco Faulí 2019-03-12 19:38:46 UTC
This is a duplicate of bug 123416.
Please, try again with LibreOffice 6.2.1.2

*** This bug has been marked as a duplicate of bug 123416 ***
Comment 11 Archisman Panigrahi 2019-09-13 19:33:27 UTC
The bug is still there in Libreoffice Build ID: 1:6.3.1~rc2-0ubuntu0.18.04.1~lo1, Running in KDE Neon 5.16.4, when `libreoffice-kde` is not installed. (I prefer to use the GTK theme of Libreoffice, as that looks better than the plasma theme)
Comment 12 Samuel Mehrbrodt (CIB) 2019-10-09 10:26:25 UTC

*** This bug has been marked as a duplicate of bug 124391 ***