Download it now!
Bug 122331 - Autofilter disappeared after export to XLSX
Summary: Autofilter disappeared after export to XLSX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.2 target:7.0.0
Keywords: bibisected, bisected, filter:xlsx, regression
Depends on:
Blocks: XLSX-Autofilter
  Show dependency treegraph
 
Reported: 2018-12-26 07:11 UTC by Roman Kuznetsov
Modified: 2020-04-08 13:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with Autofilter (44.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-12-26 07:13 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-12-26 07:11:35 UTC
Description:
Autofilter dissapeared after export to XLSX

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Steps to Reproduce:
1. Open file from attach
2. Save it as XLSX (MSO 2007-2019)
3. Open XLSX in LO or MSO
4. Autofilter dissapeared

Actual Results:
Autofilter dissapeared after export to XLSX

Expected Results:
There is Autofilter after export to XLSX


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-12-26 07:13:20 UTC
Created attachment 147829 [details]
Example with Autofilter
Comment 2 Roman Kuznetsov 2018-12-26 07:21:21 UTC
don't repro in

Версия: 6.1.2.1
ID сборки: 65905a128db06ba48db947242809d14d3f9a93fe
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: group threaded

->regression
Comment 3 Timur 2018-12-26 13:19:35 UTC
Repro 6.3+. Looks like reason is not links, but size. Works for 3 rows.
Comment 4 Roman Kuznetsov 2018-12-26 17:44:46 UTC
$ git bisect bad
6a4603a88189d5dbbf6b7ba0df93d5dff826d7db is the first bad commit
commit 6a4603a88189d5dbbf6b7ba0df93d5dff826d7db
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Aug 16 00:19:17 2018 -0700

    source sha:c135f51b050dfa7ef095fe8a5b73cde37219a8dd

https://gerrit.libreoffice.org/#/c/59134/

CC: Noel Grandin
Comment 5 Commit Notification 2018-12-26 20:43:44 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d080cd838c7ab182e70ed5e8c1deff10b2306f24%5E%21

tdf#122331 Autofilter disappeared after export to XLSX

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2018-12-27 09:37:03 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 936f6a85649c0fd71eee484e7399d445f4040586
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, Thanks for fixing this!!

Cherry-picked to 6.2: https://gerrit.libreoffice.org/#/c/65635/
Comment 7 Commit Notification 2018-12-27 10:34:37 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/316e43730713b6c69318f8d4f1d093fcc862d5b7%5E%21

tdf#122331 Autofilter disappeared after export to XLSX

It will be available in 6.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-04-08 13:52:21 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/95dbfd517240666e5b9a9fd7ac1d47d799235a62

tdf#122331: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.